Bug 64829 - upgrade failure gives incorrect feedback
upgrade failure gives incorrect feedback
Status: CLOSED DUPLICATE of bug 64828
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 05:02 EDT by bastiaan
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 05:02:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bastiaan 2002-05-13 05:02:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
The installer doesn't give any useful feedback in case of an upgrade failure,
leaving the user with an unusable system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH 7.2 with KDE
2.upgrade to RH 7.3
3.wait for error dialog at upgrade of kdebase
	

Actual Results:  The installer displays an completely uninformative error
dialog, suggesting the problem may be related to disk space, media errors, or
faulty hardware. 

Expected Results:  The installer should have displayed the actual error message
'rpm -u kdebase' would have given. 

Additional info:

This bug is triggered by bug #64650. 
I've set 'Severity' to high, because the failed upgrade leaves the system in an
unusable state (no login possible, only single user mode).
Also I feel this bug sets a dangerous precedent for RH towards 'development
Remond style': keep the user totally ignorant about what's going on, and tell 'm
he's out of luck if something goes wrong :-(
Comment 1 bastiaan 2002-05-13 05:04:08 EDT

*** This bug has been marked as a duplicate of 64828 ***

Note You need to log in before you can comment on or make changes to this bug.