Bug 648340 - /dev/eth* devices no longer created or symlinked; only /dev/.udev/db/net:eth* present
/dev/eth* devices no longer created or symlinked; only /dev/.udev/db/net:eth*...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-31 23:34 EDT by Jason Farrell
Modified: 2010-11-04 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-04 12:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2010-10-31 23:34:00 EDT
Description of problem:
After a fresh install and yum update of F14, the standard network device nodes are no longer being created by udev as /dev/foo, although the actual devices are present and configured. This can't possibly be by design; a lot of software and humans depend on those very old and very convenient device paths.

evidence:

[root@ion ~]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:01:2E:27:21:F8  
          inet addr:192.168.1.42  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::201:2eff:fe27:21f8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:69292 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66908 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:42942387 (40.9 MiB)  TX bytes:14089200 (13.4 MiB)
          Interrupt:20 Base address:0xe000 

[root@ion ~]# ll /dev/eth0
ls: cannot access /dev/eth0: No such file or directory
[root@ion ~]# find /dev -name '*eth*'
/dev/.udev/db/net:eth0
[root@ion ~]# ll /dev/.udev/db/net*
-rw-r--r--. 1 root root 141 Oct 31 22:33 /dev/.udev/db/net:eth0
-rw-r--r--. 1 root root 181 Oct 31 22:33 /dev/.udev/db/net:wlan0
[root@ion ~]# grep -r eth /etc/udev/
/etc/udev/rules.d/70-persistent-net.rules:# PCI device 0x10de:0x0ab0 (forcedeth)
/etc/udev/rules.d/70-persistent-net.rules:SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:01:2e:27:21:f8", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
Comment 1 Harald Hoyer 2010-11-04 12:15:54 EDT
Linux never had /dev/eth* as far as I can remember :)
Comment 2 Jason Farrell 2010-11-04 13:38:11 EDT
I must be going insane then.

Note You need to log in before you can comment on or make changes to this bug.