Bug 64860 - SNMP Perl module dumps core
SNMP Perl module dumps core
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
http://sourceforge.net/forum/forum.ph...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 13:43 EDT by Hrunting Johnson
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-28 05:58:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hrunting Johnson 2002-05-13 13:43:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
The C-based perl module SNMP.pm included with the ucd-snmp source (and the 
source rpm) compiles, but dumps core.  The problem is caused by some invalid 
code in the mib.c module.  The Net-SNMP project has released 4.2.5, which fixes 
this problem and another problem with the perl module (an error in t/mib.t).  I 
would recommend just copying out the two one-line fixes from the code there to 
fix the issue with the perl module.

For an example of why having a working, compilable version of the perl module 
is important, see bug 64138.  I wholly concur about that bug's needs.  The SNMP 
perl-module should at least be available as an add-on package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile perl module that comes with net-snmp source
2. run make test

	

Actual Results:  module dumps code whenever doing mib-related symbol lookups

Expected Results:  module should successfully perform mib-related symbol lookups

Additional info:

see bug 64138 for reasons why RedHat should pay attention to the included 
portions (including the perl module) of Net-SNMP.
Comment 1 Phil Knirsch 2002-05-21 08:51:33 EDT
I've updated bug 64138 with what i wanted to write here: I've updated ucd-snmp
to version 4.2.5, so things should work now.

I've verified that the make test of the perl-SNMP module now works nearly
completely (fails only for a few things, but nothing serious FWICT).

Read ya, Phil
Comment 2 Phil Knirsch 2003-03-28 05:58:46 EST
In the next upcoming release we will provide a net-snmp-package again coming
along with the net-snmp package.

A rawhide version will be available soon.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.