Bug 64861 - matrox g550 and high res doesn't work
matrox g550 and high res doesn't work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 13:47 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 16:42:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile running X11 with high res and original redhat drivers (25.99 KB, text/plain)
2002-05-14 02:42 EDT, Need Real Name
no flags Details
Configuration files as created with XConfigurator (1.73 KB, text/plain)
2002-05-14 02:43 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-05-13 13:47:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
After configuring a Matrox G550 card attached by DVI cable to an LG Flatron
L1800P TFT display only resolutions up to 800x600 work. If thje resolution is
higher, the display switsches off saying that the input signal is out of range.
When I download the beta linux XFree86 drivers from matrox, higher resolutions
work but the mouse pointer looks like a barcode...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure XFree with XConfigurator
2. Graphics card and TFT panel are reconized correctly
3. do not use automatic configuration, enter 32 MB RAM, no clockchip detection
and a resolution higher than 800 x 600 (the color depth doesn't affect the issue).
4. startx

Actual Results:  the screen gets black and the osd say "signal out of range"

Expected Results:  a working xfree desktop should appear :-)

Additional info:
Comment 1 Mike A. Harris 2002-05-13 14:32:42 EDT
Please attach your XFree86 log and config file as separate file attachments
using the link below.
Comment 2 Need Real Name 2002-05-14 02:42:43 EDT
Created attachment 57212 [details]
Logfile running X11 with high res and original redhat drivers
Comment 3 Need Real Name 2002-05-14 02:43:56 EDT
Created attachment 57213 [details]
Configuration files as created with XConfigurator
Comment 4 Mike McLean 2003-01-02 14:56:10 EST
This bug has been inappropriately marked MODIFIED. Please review the bug life
cycle information at 
http://bugzilla.redhat.com/bugzilla/bug_status.cgi

Changing bug status to ASSIGNED.
Comment 5 Ross Burton 2003-05-08 07:15:05 EDT
Also seeing this in RH9 with Iiyama 17" TFT.

This is also a Debian bug, see:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=175911.

People there claim that installing the closed Matrox drivers work, but the
binaries crash X for my RH9 install, and I can't build the source. :(
Comment 6 Mike A. Harris 2004-08-31 09:03:46 EDT
Please try Fedora Core 2, with X.org X11 6.7.0, to test if this problem
still exists.  If it is still reproduceable there, and also with
the rawhide xorg-x11-6.7.99.903 or later rpms installed on FC2, then
please file a bug report in the upstream X.Org bugzilla, which is
located at:  http://bugs.freedesktop.org in the "xorg" component.
You can also paste your upstream bug report URL here if you'd like
us to also track the issue in the upstream bugzilla.

Thanks in advance.

Setting status to "MODIFIED" pending reporter testing of FC2 and/or
rawhide X.org release.

Note You need to log in before you can comment on or make changes to this bug.