Bug 648664 - Subversion cannot export files with spaces in the filename
Summary: Subversion cannot export files with spaces in the filename
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: subversion
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-01 21:21 UTC by David Shaw
Modified: 2011-01-18 21:34 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-18 21:34:54 UTC


Attachments (Terms of Use)

Description David Shaw 2010-11-01 21:21:54 UTC
Description of problem:

Using subversion 1.6.13, "svn export" does not work on files with spaces in the filenames.

Version-Release number of selected component (if applicable):

subversion-1.6.13-1.fc13.i686

Steps to Reproduce:
1. echo "hello there" > hi\ there.txt
2. svn add hi\ there.txt
3. svn commit -m "Add a file with spaces"
4. svn export hi\ there.txt  

Actual results:

svn: 'hi%20there.txt' is not under version control

Expected results:

"Export complete."

Additional info:

This seems to be a regression somewhere between 1.6.6 from F11 and 1.6.13 from F13.  It works properly with 1.6.6.

Comment 1 David Shaw 2010-11-03 19:11:04 UTC
I can confirm this is is in subversion-1.6.13-1.fc14.i686 as well

Comment 2 Fedora Update System 2011-01-04 14:36:24 UTC
subversion-1.6.15-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/subversion-1.6.15-1.fc14

Comment 3 Fedora Update System 2011-01-04 20:56:17 UTC
subversion-1.6.15-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update subversion'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/subversion-1.6.15-1.fc14

Comment 4 Fedora Update System 2011-01-18 21:34:37 UTC
subversion-1.6.15-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.