Bug 64870 - Please make rhn_applet use intltool
Please make rhn_applet use intltool
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 16:17 EDT by Christian Rose
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-18 06:33:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2002-05-13 16:17:09 EDT
Please consider making rhn_applet use intltool. This will significantly ease 
the translation of the .desktop file entries for translators, since they can be 
translated and maintained directly from the po file.
Comment 1 Daniel Veillard 2003-01-17 10:55:05 EST
Can you provide instructions (or pointers) on how to do so ?
Patch or example code for python appreciated,

Daniel
Comment 2 Christian Rose 2003-01-18 06:22:33 EST
Kenneth is the intltool wizard... Kenneth?

Otherwise, there are many other bug reports that also request intltool support;
some of them seems to be resolved, and some of them may of course involve python
code: Bug 40063, bug 40064, bug 40226, bug 64845, bug 64871, bug 64872, bug
64873, bug 64874, bug 64875, bug 64876, 64877, bug 64878, bug 64879, bug 64880,
bug 64881.
Comment 3 Daniel Veillard 2003-01-18 06:33:23 EST
Okay looking at the intltool-0.22/README, all the instructions indicates
that this is targetting packages using autocon and automake. this is not
the case for the rhn-applet code. There is no instructions for non
automake based setups, I won't try to make this works against what seems
the expected framework for intltool. If you know how to do it, provide
patches, but I won't mess with it myself

Daniel
Comment 4 Kenneth Rohde Christiansen 2003-01-18 10:42:16 EST
It really isnt that hard.

Create a po/ dir.
Add a po/POTFILES.in file, including the path to the somename.desktop.in file

Then to create the somename.desktop file all you do is:

$ intltool-merge po/ -d -u -c po/.intltool-merge-cache somename.desktop.in
somename.desktop

you can also type intltool-merge --help for a bit more info.

Note You need to log in before you can comment on or make changes to this bug.