Bug 648862 - segfault in gnome-volume-control
segfault in gnome-volume-control
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-media (Show other bugs)
5.6
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Bastien Nocera
Desktop QE
: Regression, Reopened
Depends On:
Blocks: 640580 1002709
  Show dependency treegraph
 
Reported: 2010-11-02 07:08 EDT by Tomas Pelka
Modified: 2013-10-06 21:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:37:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
g-v-c backtrace (6.94 KB, application/octet-stream)
2010-11-02 07:08 EDT, Tomas Pelka
no flags Details
backtrace on Snap3 (3.56 KB, text/plain)
2010-11-30 09:45 EST, Tomas Pelka
no flags Details

  None (edit)
Description Tomas Pelka 2010-11-02 07:08:33 EDT
Created attachment 457150 [details]
g-v-c backtrace

Description of problem:
Segfault in gnome-volume-control when starting. After update from Alpha 1 to Beta 1.


Version-Release number of selected component (if applicable):
gnome-media-2.16.1-3.el5
glibc-2.5-56
gstreamer-plugins-base-0.10.20-3.0.1.el5_3


How reproducible:
100%

Steps to Reproduce:
1. run g-v-c or right-click on Volume applet and hit Open Volume Control.
2.
3.
  
Actual results:
Sefault, see attached backtrace.

Expected results:


Additional info:
x86_64
Comment 1 Tomas Pelka 2010-11-02 07:19:49 EDT
Stdout:
=======

[tpelka@dhcp-2-211 ~]$ gnome-volume-control 

(process:11406): GStreamer-WARNING **: The GStreamer function gst_init_get_option_group() was
        called, but the GLib threading system has not been initialised
        yet, something that must happen before any other GLib function
        is called. The application needs to be fixed so that it calls
           if (!g_thread_supported ()) g_thread_init(NULL);
        as very first thing in its main() function. Please file a bug
        against this application.
Comment 2 Bastien Nocera 2010-11-02 09:57:57 EDT
What version of glib2 is installed on that system?
Comment 3 Tomas Pelka 2010-11-03 04:08:43 EDT
glib2-2.12.3-4.el5_3.1
Comment 4 Vladimir Benes 2010-11-12 10:59:32 EST
have you lookied into this issue? I cannot reproduce it on my box so it can be caused by some alpha -> beta update or so
Comment 5 Tomas Pelka 2010-11-15 09:51:23 EST
OK create a new user, clean up things a bit and it works as expected. Closing as NOTABUG.
Comment 6 Tomas Pelka 2010-11-30 09:45:28 EST
Created attachment 463748 [details]
backtrace on Snap3

Meet again on Snapshot3, glib2-2.12.3-4.el5_3.1
Comment 7 Tomas Pelka 2010-12-03 07:07:32 EST
I've installed clean rhel5.6 today (20101202) and problem is still in.
Comment 8 Bastien Nocera 2010-12-07 09:57:41 EST
Try downgrading to gstreamer 0.10.9 (which was available in GA) and let me know whether you see the same problem.

We update to 0.10.20 more than 2 years ago though.
Comment 14 Ludek Smid 2011-06-21 08:53:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.7 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 15 Brian Gollaher 2011-09-02 12:25:33 EDT
Moving to 5.9.
Comment 19 Andrius Benokraitis 2013-10-06 21:37:29 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.