Bug 648910 - crash on evolution-data-server-1.12: search.c:77: ldap_search_ext: Assertion `( (ld)->ld_options.ldo_valid == 0x2 )' failed.
crash on evolution-data-server-1.12: search.c:77: ldap_search_ext: Assertion ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
5.6
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
: Patch
Depends On: 576136
Blocks: 743405 1002709 569781
  Show dependency treegraph
 
Reported: 2010-11-02 09:40 EDT by ritz
Modified: 2013-10-06 21:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (28.66 KB, patch)
2010-11-02 09:40 EDT, ritz
no flags Details | Diff

  None (edit)
Description ritz 2010-11-02 09:40:36 EDT
Created attachment 457167 [details]
patch based on upstream code

Description of problem:
 autocompletion request sometimes causes the evolution-data-server-1.12 process to crash

Looking at the all the evolution processes (debugging enabled) this seems to coincide with the data-server printing this last line of output before exiting:
evolution-data-server-1.12: search.c:77: ldap_search_ext: Assertion `( (ld)->ld_options.ldo_valid == 0x2 )' failed.


Version-Release number of selected component (if applicable):
evolution-data-server-1.12.3-18

How reproducible:
frequent

Steps to Reproduce:
1. Use auto-completion 
2.
3.
  
Actual results:
crash

Expected results:
should not crash

Additional info:
https://bugzilla.gnome.org/show_bug.cgi?id=303067
Comment 1 RHEL Product and Program Management 2011-05-31 11:07:11 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-06-11 21:26:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 Andrius Benokraitis 2013-10-06 21:46:39 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.