Bug 64896 - named doesn't restart after suspend/resume
Summary: named doesn't restart after suspend/resume
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apmd   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-14 00:00 UTC by Need Real Name
Modified: 2014-03-17 02:27 UTC (History)
3 users (show)

Fixed In Version: 3.0.2-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 20:56:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified apmscript which will restart named after suspend/resume (12.26 KB, text/plain)
2002-05-14 12:18 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-05-14 00:00:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i586; U;) Gecko/20020408

Description of problem:
The named service fails to restart after a suspend/resume cycle.

From my /var/log/messages:
May 11 12:32:50 slick apmd[738]: System Suspend
May 11 12:33:01 slick kernel: usb-uhci.c: interrupt, status 20, frame# 0
May 11 12:33:01 slick kernel: usb-uhci.c: Host controller halted, trying to restart.
May 11 12:33:05 slick named[23256]: starting BIND 9.2.0 -u named
May 11 12:33:05 slick named[23256]: using 1 CPU
May 11 12:33:05 slick named[23259]: loading configuration from '/etc/named.conf'
May 11 12:33:05 slick named[23259]: no IPv6 interfaces found
May 11 12:33:05 slick named[23259]: ifiter_ioctl.c:218: REQUIRE(iter->pos <
(unsigned int) iter->ifc.ifc_len) failed
May 11 12:33:05 slick named[23259]: exiting (due to assertion failure)
May 11 12:33:05 slick named: named startup succeeded
May 11 12:33:05 slick kernel: PCI: Found IRQ 11 for device 02:06.0
May 11 12:33:05 slick kernel: PCI: Sharing IRQ 11 with 00:1f.2
May 11 12:33:05 slick kernel: PCI: Sharing IRQ 11 with 02:06.1
May 11 12:33:05 slick kernel: PCI: Sharing IRQ 11 with 02:0f.0
May 11 12:33:05 slick kernel: PCI: Sharing IRQ 11 with 02:0f.1
May 11 12:33:05 slick kernel: PCI: Sharing IRQ 11 with 02:0f.2
May 11 12:33:05 slick kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
May 11 12:33:05 slick kernel: 02:06.0: 3Com PCI 3c556 Laptop Tornado at 0xe800.
Vers LK1.1.16
May 11 12:33:07 slick netfs: Mounting other filesystems:  succeeded
May 11 12:33:08 slick netfs: Mounting other filesystems:  succeeded
May 11 12:33:08 slick apmd[738]: Normal Resume after 00:00:18 (59% 3:10) Battery
power

The problem seems to be in /etc/sysconfig/apm-scripts/apmscript -- actually in
the /var/run/apm-resume-post script created by the apmscript:  the script
attemtps to start the named service before the network interfaces are brought
back up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install apmd
2. install bind
3. suspend/resume
	

Actual Results:  named service does not start back up after resume

Expected Results:  named service should start back up after resume

Additional info:

Comment 1 Matthias Runge 2002-05-14 08:43:32 UTC
I've seen the same on my laptop. I've changed the order in 
starting /restarting pcmcia/cardbus drivers and the processes
(e.g. named), but nothing changed: same error (assertion failure) 
in syslog.

Comment 2 Need Real Name 2002-05-14 12:18:35 UTC
Created attachment 57245 [details]
modified apmscript which will restart named after suspend/resume

Comment 3 Need Real Name 2002-05-14 12:20:17 UTC
Simply changing the order in apmscript is not enough, because the script checks
to see if the service (named) is listed in $RESTORESERVICES and if the service
(named) is running.  If you simply move the network restart section so that it's
earlier that the service restart section (so that the network will be up when
the named service restart is attemped after resume), then the named service will
stop (because the network isn't up) before the suspend and then it won't be
started at resume.  

You can make the apmscript work by moving the restore services section of the
script below the restore network section, and disble checking whether the
services in $RESTORESERVICES are active (ie, trust that everything in
$RESTORESERVICES should always be started after a resume).

I've attached my modified apmscript, which works for me.

Comment 4 Matthias Runge 2002-05-14 12:44:16 UTC
Thank you. This works for me too. (but I still don't know, why this really
helps.) 


Comment 5 Bill Nottingham 2003-05-19 20:56:39 UTC
Fixed in 3.0.2-19.


Note You need to log in before you can comment on or make changes to this bug.