Bug 649067 - Text mode produces blank pdf
Summary: Text mode produces blank pdf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: simple-scan
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-02 20:58 UTC by Iván Jiménez
Modified: 2011-03-21 20:57 UTC (History)
5 users (show)

Fixed In Version: simple-scan-2.32.0.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-21 20:57:59 UTC


Attachments (Terms of Use)
screenshot of a page in simple-scan and corresponding pdf (396.85 KB, image/png)
2010-11-02 20:58 UTC, Iván Jiménez
no flags Details

Description Iván Jiménez 2010-11-02 20:58:21 UTC
Created attachment 457287 [details]
screenshot of a page in simple-scan and corresponding pdf

Description of problem:
Scanning in text mode produces a blank pdf.

Version-Release number of selected component (if applicable):
simple-scan-2.32.0-1.fc14.x86_64
cairo-1.10.0-2.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. scan in text mode
2. save it
3. open the resulting pdf
  
Actual results:
a blank pdf

Expected results:
a pdf with the scanned images as in f13

Additional info:
i think maybe this has to do with cairo, as happened in gimp.

Comment 1 Jimmy Thrasibule 2010-11-15 17:09:51 UTC
I have got the same problem here :

$ cat /etc/issue
Fedora release 14 (Laughlin)
Kernel \r on an \m (\l)

$ rpm -qa simple-scan
simple-scan-2.31.91-1.fc14.x86_64

$ evince simplescan.pdf 
Error (89954): Unknown operator ',559998'
Error (89969): Unknown operator ',919983'
Error (89980): Too few (2) args to 'cm' operator
Error (89954): Unknown operator ',559998'

This bug seems to be solved in the 2.32.0.1 release of simple-scan https://bugs.launchpad.net/ubuntu/maverick/+source/simple-scan/+bug/644734.

Is an update for this package is planned?

Comment 2 tom-ipp 2010-12-18 17:49:00 UTC
Hi,
the 2.32.0.1 version of simple-scan is built for fedora15, according to koji. Could we have an update for fedora14, please...
Thanks.

Comment 3 tom-ipp 2010-12-18 17:54:43 UTC
Hi again,
there is a simple workaround:
from simple-scan one can print and select file type pdf.
-> the file is then ok for me.

Comment 4 Iván Jiménez 2011-01-20 02:25:27 UTC
Could the 2.32.0.1 version be submitted as an update for f14? the package from koji works fine.

Comment 5 Fedora Update System 2011-03-01 07:17:43 UTC
Package simple-scan-2.32.0.1-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing simple-scan-2.32.0.1-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/simple-scan-2.32.0.1-1.fc14
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-03-02 01:53:54 UTC
simple-scan-2.32.0.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update simple-scan'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/simple-scan-2.32.0.1-1.fc14

Comment 7 Fedora Update System 2011-03-21 20:57:30 UTC
simple-scan-2.32.0.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.