Bug 64910 - unexpected locale settings break rpm scriptlets
unexpected locale settings break rpm scriptlets
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 07:13 EDT by Nigel Metheringham
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-14 07:13:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Metheringham 2002-05-14 07:13:21 EDT
Description of Problem:

rpm uses the current locale to do shell globbing giving unexpected results.

Version-Release number of selected component (if applicable):

4.0.4-7x

How Reproducible:

Every time...

Steps to Reproduce:
1. Produce spec file with an expression like the following in %files section
   %doc [A-Z][A-Z]*

   intended to pick up the README etc files but miss Makefile...
   Have your own locale settings set normally - ie for me
     speedy ~ 254> locale
     LANG=en_GB
     LC_CTYPE="en_GB"
     LC_NUMERIC="en_GB"
     LC_TIME="en_GB"
     LC_COLLATE="en_GB"
     LC_MONETARY="en_GB"
     LC_MESSAGES="en_GB"
     LC_PAPER="en_GB"
     LC_NAME="en_GB"
     LC_ADDRESS="en_GB"
     LC_TELEPHONE="en_GB"
     LC_MEASUREMENT="en_GB"
     LC_IDENTIFICATION="en_GB"
     LC_ALL=

2. Build package - ie rpmbuild -ba package.spec
   Watch rpm put pretty much every file in the top directory into the
   documentation dir - whether they start with caps or not
3. 

Actual Results:


Expected Results:


Additional Information:
	
Suggest you force LC_COLLATE (and maybe others?) to C within rpm
Comment 1 Jeff Johnson 2002-05-14 10:25:30 EDT
Yup. I choose to view the (ahem) problem as a build
system configuration feature, outside the scope of rpm,
as there's no way I can get the locale correct for all
possible builds.

Heck, you're in en_GB and glob(3) is broke :-)
Comment 2 Nigel Metheringham 2002-05-14 11:03:13 EDT
Was going to comment that shells on teh systems appeared to be working
round this, but more detailed checking shows *some* shells do
   echo [A-Z]*
as expected, and others don't.

I'm pining for the days of real ASCII and sod the locales.


Note You need to log in before you can comment on or make changes to this bug.