Bug 649150 - hamster-applet has missing dependencies
Summary: hamster-applet has missing dependencies
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: hamster-applet
Version: 14
Hardware: All
OS: Unspecified
low
high
Target Milestone: ---
Assignee: Mads Villadsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-03 02:08 UTC by Cristian Ciupitu
Modified: 2010-11-06 00:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-06 00:11:28 UTC
Type: ---


Attachments (Terms of Use)
My /var/log/rpmpkgs (32.12 KB, application/octet-stream)
2010-11-03 02:08 UTC, Cristian Ciupitu
no flags Details
0001-Require-dbus-python.patch (690 bytes, patch)
2010-11-03 02:19 UTC, Cristian Ciupitu
no flags Details | Diff

Description Cristian Ciupitu 2010-11-03 02:08:55 UTC
Created attachment 457329 [details]
My /var/log/rpmpkgs

Description of problem:
I can not use the hamster applet, nor can I run hamster-cli.

Version-Release number of selected component (if applicable):
hamster-applet-2.31.91-1.fc14.noarch.rpm

How reproducible:
Every time.

Steps to Reproduce:
1. hamster-cli --help

Actual results:
Traceback (most recent call last):
  File "/usr/bin/hamster-cli", line 29, in <module>
    from hamster import client, stuff
  File "/usr/lib/python2.7/site-packages/hamster/client.py", line 24, in <module>
    import dbus, dbus.mainloop.glib
ImportError: No module named dbus

Expected results:
No errors.

Additional info:
Installing dbus-python fixed the problem.

Comment 1 Cristian Ciupitu 2010-11-03 02:19:38 UTC
Created attachment 457330 [details]
0001-Require-dbus-python.patch

Run  git am 0001-Require-dbus-python.patch  to apply it.

Comment 2 Fedora Update System 2010-11-03 22:20:36 UTC
hamster-applet-2.32.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/hamster-applet-2.32.0-2.fc14

Comment 3 Fedora Update System 2010-11-04 23:49:37 UTC
hamster-applet-2.32.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hamster-applet'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/hamster-applet-2.32.0-2.fc14

Comment 4 Carl G. 2010-11-05 23:50:09 UTC
The update above got unpushed due to the negative karma. Is it fixed in hamster-applet-2.32.0-3.fc14?

Comment 5 Mads Villadsen 2010-11-06 00:11:28 UTC
Yes, it is fixed in 2.32.0-3 as well.


Note You need to log in before you can comment on or make changes to this bug.