Bug 64926 - unable to use atalk names with blanks inside
unable to use atalk names with blanks inside
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: netatalk (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 13:03 EDT by Leonhard Zachl
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-14 13:03:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonhard Zachl 2002-05-14 13:03:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 (X11; U; Linux 2.4.19-pre6 i686)

Description of problem:
because of missing (quoted) quotes in the atalk startscript its not possible to use Atalk Names with blanks inside e.g. "Central Services". afpd terminates with usage..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. in /etc/atalk/config enter:
   ATALK_NAME="Central Services"
2. start atalk

Additional info:

here is the patch

--- /etc/rc.d/init.d/atalk.orig Tue May 14 18:41:51 2002
+++ /etc/rc.d/init.d/atalk      Tue May 14 18:42:11 2002
@@ -31,7 +31,7 @@
                    daemon papd -f /etc/atalk/papd.conf
                fi
                if [ ${AFPD_RUN} = yes ] ; then
-                   daemon afpd -c ${AFPD_MAX_CLIENTS} -n ${ATALK_NAME} -f /etc/atalk/AppleVolumes.default -s /etc/atalk/AppleVolumes.system
+                   daemon afpd -c ${AFPD_MAX_CLIENTS} -n \"${ATALK_NAME}\" -f /etc/atalk/AppleVolumes.default -s /etc/atalk/AppleVolumes.system
                fi
            } >/dev/null &
        else
@@ -42,7 +42,7 @@
                daemon papd -f /etc/atalk/papd.conf
            fi
            if [ ${AFPD_RUN} = yes ] ; then
-               daemon afpd -c ${AFPD_MAX_CLIENTS} -n ${ATALK_NAME} -f /etc/atalk/AppleVolumes.default -s /etc/atalk/AppleVolumes.system
+               daemon afpd -c ${AFPD_MAX_CLIENTS} -n \"${ATALK_NAME}\" -f /etc/atalk/AppleVolumes.default -s /etc/atalk/AppleVolumes.system
            fi
        fi
        echo
Comment 1 Phil Knirsch 2002-05-27 04:23:15 EDT
Patch looks fine, will be included in next version (1.5.2-4) available soon via
rawhide.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.