Bug 64930 - rpm-4.0.4-7x.18 segfaults when installing a package which uses a nonexistent group
rpm-4.0.4-7x.18 segfaults when installing a package which uses a nonexistent ...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 15:03 EDT by Jonathan Kamens
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-14 15:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-05-14 15:03:00 EDT
I tried to install <URL:http://www.mit.edu/~jik/xrn-9.03b15-1jik.i386.rpm> with
rpm-4.0.4-7x.18 with "rpm -i xrn-9.03b15-1.jik.i386.rpm".  It segfaulted.

Then I tried "/usr/lib/rpm/rpmi -i xrn-9.03b15-1jik.i386.rpm".  It worked and
generated a bunch of warnings of the form "warning: group jik does not exist -
using root".

Then I tried rebuilding the package with "%defattr(-,root,root)", which of
course I should have done in the first place.  The new package,
<URL:http://www.mit.edu/~jik/xrn-9.03b15-2jik.i386.rpm>, installed with "rpm -i"
without any errors.

I'm not going to attach the RPMs because I'm not sure you want 198KB RPMs
cluttering up Bugzilla.  If you want to attach them, you can download and attach
them, or if I should do it, let me know.  I'll try to leave them at the URLs
above until the contents of this ticket imply that they're no longer needed.
Comment 1 Jeff Johnson 2002-05-17 10:44:50 EDT
Hmmm, here's what I see:

bash$ sudo rpm -i xrn-9.03b15-1jik.i386.rpm 
warning: user jik does not exist - using root
warning: group jik does not exist - using root
warning: user jik does not exist - using root
warning: group jik does not exist - using root
warning: user jik does not exist - using root
warning: group jik does not exist - using root
warning: user jik does not exist - using root
warning: group jik does not exist - using root
warning: user jik does not exist - using root
warning: group jik does not exist - using root
warning: user jik does not exist - using root
warning: group jik does not exist - using root
warning: user jik does not exist - using root
warning: group jik does not exist - using root
warning: user jik does not exist - using root
warning: group jik does not exist - using root
bash$ rpm --version
RPM version 4.0.4
bash$ rpm -q rpm
rpm-4.0.4-7x.18

Dunno what's up, please reopen with more info
so I can reproduce. Perhaps you're using
LDAP passwrods? There's an insoluble segfault
with PAM vis a vis statically linked binaries
like rpm, the workaround is to run nscd.

Note You need to log in before you can comment on or make changes to this bug.