Bug 64940 - http kickstart syntax wrong
http kickstart syntax wrong
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhl-cg (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
:
: 65796 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 18:15 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-03 18:55:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-14 18:15:44 EDT
Description of Problem:

http://www.redhat.com/docs/manuals/linux/RHL-7.2-Manual/custom-guide/s1-kickstart2-startinginstall.html

This page documents the http syntax as:

ks=http:server:/path/to/ks.cfg

This does not work on the 7.2 kickstart.  The syntax that does work is:

ks=http://server/path/to/ks.cfg

The 7.3 rhl-cg has the same syntax as the 7.2 rhl-cg, but we have not tested to
see which syntax 7.3 accepts.
Comment 1 Tammy Fox 2002-05-31 15:35:30 EDT
*** Bug 65796 has been marked as a duplicate of this bug. ***
Comment 2 Tammy Fox 2002-05-31 15:41:06 EDT
Does nfs need to say ks=nfs://server/path/to/ks.cfg also?
Comment 3 Need Real Name 2002-05-31 18:28:40 EDT
I have not tried this with 7.3, but the NFS syntax we have used 
in the past was:

nfs --server 10.0.0.1 --dir /redhat/linux/6.2/en/os/i386/

This was known to work in 6.2, 7.0 and 7.1 at least.
Comment 4 Need Real Name 2002-05-31 18:39:20 EDT
Doh! disregard that.  That's from the kickstart files on where to install from,
not what to pass on the command line for where to pull the kickstart itself
from.  If I have time to test out loading the kickstart file itself off NFS,
I'll give it a try, but it will be about 2 weeks before I may be able to experiment.
Comment 5 Tammy Fox 2002-06-03 18:55:22 EDT
Ok. I fixed the http syntax on the website and in CVS.
Comment 6 Tammy Fox 2002-06-04 19:28:01 EDT
NFS needs the colon.

Note You need to log in before you can comment on or make changes to this bug.