Bug 64959 - problem with airo.o and airo_cs.o wireless modules
problem with airo.o and airo_cs.o wireless modules
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 22:42 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-14 22:42:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-14 22:42:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
The airo.o and airo_cs.o wireless driver modules are include twice - once in
/lib/modules/2.4.18-x/kernel/drivers/net/pcmcia and once in
/lib/modules/2.4.18-x/net/drivers/wireless. The drivers is the pcmcia directory
are loaded by default and appear old. They do not support encryption. The
problem can be fixed by removing the drivers in the pcmcia directory and running
depmod.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run iwconfig
2.
3.
	

Actual Results:  receive error that ethx is compiled with wireless tools 1 and
we are using wireless tools 12

Additional info:
Comment 1 Doug Ledford 2002-05-16 15:17:19 EDT
Although the paths you listed were a bit off (which caused me to originally
think you were wrong, the actual paths are
/lib/modules/2.4.18-*/kernel/drivers/net/{wireless,pcmcia}), it turns out that
there are indeed two versions of the airo driver.  We've disabled the older
driver in our current source tree and this should be reflected in future kernels.

Note You need to log in before you can comment on or make changes to this bug.