Bug 64967 - (mga g400) starting gnome after switchdesk hangs
(mga g400) starting gnome after switchdesk hangs
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: switchdesk (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks: 82777
  Show dependency treegraph
 
Reported: 2002-05-15 04:36 EDT by Joachim Backes
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-16 02:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2002-05-15 04:36:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18 i686)

Description of problem:
Standardly, I am running the gnome desktop as my standard desktop.
Now, I switched to kde by the switchdesk tool, logged out und started x again.
Then the KDE desktop is running correctly.

Now, I switched back to gnome using again switchdesk, then I shut down X and
started X again for getting my gnome desktop. But during starting up X, X hangs
up (only the X11 screen appears and the cross mouse pointer, but no gnome
greeting logo).

I rebooted. Then X start successes with a full gnome desktop.

Remark: I don't use xdm; I always start the X environment by using startx.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Take gnome as std desktop
2. Use switchdesk for selecting KDE
3. Kill X and start it again by "startx", then the KDE desktop appears and runs
4. Use switchdesk for selecting GNOME
5. Kill X and start it again by "startx", then X starts but hangs up.
	

Actual Results:  X hangs

Expected Results:  X starts the gnome desktop

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-05-21 10:31:50 EDT
All switchdesk does here is "exec gnome-session", which seems to be right... 
Havoc?
Comment 2 Havoc Pennington 2002-05-21 11:48:32 EDT
No clue - we'd need to see which process was hanging, and probably strace that
process.
Comment 3 Joachim Backes 2002-05-28 08:39:39 EDT
It seems that X can't no more load the video driver mga (my video card is a
matrox g400) when starting X after I re-switchted to gnome. 

I got the following output when starting X (which will hang):
-------------------------------------------------------------

XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-8) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
	If the server is older than 6-12 months, or if your card is
	newer than the above date, look for a newer version before
	reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.17-0.13smp i686 [ELF] 
Build Host: daffy.perf.redhat.com
 
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Tue May 28 14:28:38 2002
(==) Using config file: "/etc/X11/XF86Config-4"
modprobe: Can't locate module agpgart
[drm] failed to load kernel module "agpgart"
modprobe: Can't locate module mga
[drm] failed to load kernel module "mga"
(EE) MGA(0): [drm] DRIScreenInit failed.  Disabling DRI.
SESSION_MANAGER=local/sunny.rhrk.uni-kl.de:/tmp/.ICE-unix/1511
Comment 4 Mike A. Harris 2002-11-03 04:24:11 EST
Please attach your full X config file, and full X server log file using
the link below.  Also attach the output of the following commands:

cat /proc/version
lsmod
Comment 5 Mike A. Harris 2003-05-16 02:42:51 EDT
Insufficient data supplied in order to investigate issue.  Please feel to
reopen bug report if this problem continues with Red Hat Linux 9.  Be sure
to attach the information requested above if reopening.

Note You need to log in before you can comment on or make changes to this bug.