Bug 649710 - vgs fails to display tags when there are many of them
vgs fails to display tags when there are many of them
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper (Show other bugs)
5.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Milan Broz
Corey Marthaler
:
Depends On: 648219 648554
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-04 07:43 EDT by Ayal Baron
Modified: 2013-02-28 23:10 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, due to the output limit in reporting functions (vgs, lvs), tags seized to be displayed in longer reports. With this update, the output lines in these reports are limited by available memory only.
Story Points: ---
Clone Of: 648554
Environment:
Last Closed: 2011-01-13 17:39:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Milan Broz 2010-11-04 07:49:26 EDT
From bug #648219

The test script attached adds many tags of 80 chars (similar to what we do in
vdsm), and then immediately reads them [all] back.

After 48 tags the vgs command fails to display tags, however, it exits with
code 
0. So we have no idea that something bad just has happened.

There is a somewhat cryptic error messages that hints that some string
manipulation was failing. It looks like it comes from device mapper, so it is
not clear how it is related to the problem.
Comment 2 Milan Broz 2010-11-09 07:05:49 EST
Patch is part of device-mapper library, fixing component.
Comment 3 Milan Broz 2010-11-09 07:53:59 EST
Fix in device-mapper-1.02.55-2.el5.
Comment 5 Corey Marthaler 2010-11-09 14:41:20 EST
I once again ran the attached script with the latest rpms. The script passed, and I saw no error messages. Marking verified.

2.6.18-227.el5

lvm2-2.02.74-2.el5    BUILT: Tue Nov  9 08:03:06 CST 2010
lvm2-cluster-2.02.74-3.el5    BUILT: Tue Nov  9 08:01:59 CST 2010
device-mapper-1.02.55-2.el5    BUILT: Tue Nov  9 06:41:00 CST 2010
cmirror-1.1.39-10.el5    BUILT: Wed Sep  8 16:32:05 CDT 2010
kmod-cmirror-0.1.22-3.el5    BUILT: Tue Dec 22 13:39:47 CST 2009
Comment 6 Eva Kopalova 2010-12-14 10:19:47 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, due to the output limit in reporting functions (vgs, lvs), tags seized to be displayed in longer reports. With this update, the output lines in these reports are limited by available memory only.
Comment 8 errata-xmlrpc 2011-01-13 17:39:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0051.html

Note You need to log in before you can comment on or make changes to this bug.