Bug 64977 - scanimage unable to detect scanner initially
scanimage unable to detect scanner initially
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: sane (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-15 09:47 EDT by Ben Elliston
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Elliston 2002-05-15 09:47:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-24 alpha; Nav)

Description of problem:
After booting my system, Sane is unable to detect my scanner.  Running
"scanimage -L" twice seems to fix the problem -- the second time, the scanner is
found and from then on until the system is rebooted, the scanner can be found by
Sane.

[root@metropolis root]# scanimage  -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[root@metropolis root]# scanimage  -L
device `hp:/dev/sg1' is a Hewlett-Packard C5110A flatbed scanner

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot system.
2. Run scanimage -L.  No scanner found.
3. Run scanimage -L.  Scanner found; everything works from then on.


Expected Results:  scanimage should find the scanner the first time -L is used.

Additional info:

I am using a HP SCSI scanner which is detected by my SCSI BIOS at bootup.  My
/etc/sane.d/hp.conf file simply contains:

  scsi HP
Comment 1 Tim Waugh 2002-05-15 09:58:25 EDT
Please try the package from Red Hat Linux 7.3.  Upgrade to it using rpm, and 
then run '/sbin/ldconfig' as root (due to another bug).
Comment 2 Ben Elliston 2002-07-08 11:42:41 EDT
I upgraded to the sane package from RHL 7.3.  It had no effect.

I have managed to observe that the SCSI generic module (sg) is not loaded when
the scanner cannot be found by sane.  It seems that a number of accesses on
/dev/sg? are required to trigger the sg module to be loaded.  bcrl indicated
that this might be a known problem.

In the meantime, is there a workaround to load the sg module at boot time and
never unload it?

Ben
Comment 3 Tim Waugh 2002-07-08 11:47:43 EDT
Only putting '/sbin/modprobe sg' at the end of /etc/rc.d/rc.local. :-(
Comment 4 Bill Nottingham 2006-08-07 15:50:31 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 5 Bill Nottingham 2006-10-18 13:08:44 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.