Bug 649805 - 389-ds setup-ds-admin.pl scripts fails with Could not reliably determine the server's fully qualified domain name
389-ds setup-ds-admin.pl scripts fails with Could not reliably determine the ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: 389-ds (Show other bugs)
14
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
: Reopened, screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-04 11:40 EDT by Pasi Karkkainen
Modified: 2013-03-01 14:35 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 15:17:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pasi Karkkainen 2010-11-04 11:40:13 EDT
Description of problem:
setup-ds-admin.pl script fails with the following error:

Starting admin server . . .
output: httpd.worker: apr_sockaddr_info_get() failed for fedora01.test.local
output: httpd.worker: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Could not start the admin server.  Error: 256
Failed to create and configure the admin server
Exiting . . .
Log file is '/tmp/setup1rltOq.log'


Version-Release number of selected component (if applicable):
Fedora 13.

# rpm -qa | grep 389
389-adminutil-1.1.9-1.fc13.x86_64
389-ds-base-1.2.6.1-2.fc13.x86_64
389-admin-1.1.11-1.fc13.x86_64
389-admin-console-1.1.5-1.fc13.noarch
389-admin-console-doc-1.1.5-1.fc13.noarch
389-console-1.1.4-1.fc13.noarch
389-ds-console-1.2.3-1.fc13.noarch
389-dsgw-1.1.5-1.fc13.x86_64
389-ds-console-doc-1.2.3-1.fc13.noarch
389-ds-1.2.1-1.fc13.noarch


How reproducible:
Always.

Steps to Reproduce:
1. adduser fds
2. yum install 389-ds
3. setup-ds-admin.pl
4. choose 2. Typical setup and enter required information.
  
Actual results:

Are you ready to set up your servers? [yes]:
Creating directory server . . .
Your new DS instance 'fedora01' was successfully created.
Creating the configuration directory server . . .
Beginning Admin Server creation . . .
Creating Admin Server files and directories . . .
Updating adm.conf . . .
Updating admpw . . .
Registering admin server with the configuration directory server . . .
Updating adm.conf with information from configuration directory server . . .
Updating the configuration for the httpd engine . . .
Starting admin server . . .
output: httpd.worker: apr_sockaddr_info_get() failed for fedora01.test.local
output: httpd.worker: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Could not start the admin server.  Error: 256
Failed to create and configure the admin server
Exiting . . .
Log file is '/tmp/setup1rltOq.log'



Expected results:
Setup works OK.

Additional info:
Full logfile from setup-ds-admin.pl script available from: 
http://pasik.reaktio.net/fedora/fds/setup1rltOq.log

Does 389-ds require that server fqdn is configured in DNS server? Both forward and reverse entries?

I don't have a DNS server set up, I'm trying to install 389-ds on a minimal testing environment..

Network settings for the fedora server are like this:

# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
NETMASK=255.255.255.0
IPADDR=1.2.3.4
GATEWAY=1.2.3.1
BOOTPROTO=static
ONBOOT=yes

# cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=fedora01.test.local

# cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
1.2.3.4    fedora01.test.local     fedora01       

# cat /etc/resolv.conf
search test.local
domain test.local
nameserver 2.3.4.5
nameserver 2.3.4.6

# hostname
fedora01.test.local


Is something else required for 389-ds to work?
Comment 1 Pasi Karkkainen 2010-11-06 08:47:04 EDT
Additional info:

# getent hosts fedora01.test.local
1.2.3.4    fedora01.test.local fedora01

# getent hosts 1.2.3.4
1.2.3.4    fedora01.test.local fedora01

So that seems to be fine. Still doesn't work.
Comment 2 Rich Megginson 2010-11-08 09:31:35 EST
It's a problem with Apache, as we discussed on IRC.  Do a google search for 

apr_sockaddr_info_get() failed for

And you will find this is a common problem with Apache.  I do not believe the problem is with 389 software, nor do I believe we can do anything in 389 to fix this problem.
Comment 3 Pasi Karkkainen 2010-11-14 04:31:15 EST
This is a bit weird problem.. *all* the configuration looks OK. I've gone through those apache hits from google, and they don't help.

I also noticed this from "/var/log/dirsrv/admin-serv/error":

[alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "fedora01.test.local" Configuration Failed

I was googling for that error. Some results said it's because of missing "servername myserver" entry from apache2 config file. That entry seems to be missing from "/etc/dirsrv/admin-serv/console.conf"..

As you can see from above pastes all the basic configuration is properly set up.
I also created "/etc/hostname" with "fedora01.test.local" in it, that didn't help either..

Could it be because of that missing "servername" from console.conf ?
This is something that should be figured out and documented.. because 389-ds currently doesn't work on Fedora.
Comment 4 Pasi Karkkainen 2010-11-14 04:35:34 EST
Some docs suggest that:

"make sure your hostname is DNS-resolvable.  (Even if this is
not visible to the Internet, it still needs to resolve.)"

So maybe mod_unique_id *requires* DNS .. I don't have DNS-server on my test-only setup.
Comment 5 Pasi Karkkainen 2010-11-14 07:17:30 EST
Ok, I figured it out now. It had nothing to do with DNS or hostname settings.

It was damn SElinux !!

Setting SELINUX=disabled in "/etc/selinux/config" and rebooting before running setup-ds-admin.pl fixed it. argh.

So there's some problem in the default 389ds SElinux policy..
Comment 6 Pasi Karkkainen 2010-11-14 07:40:37 EST
I tried with Fedora 14, same problem there. I have to disable SElinux to make it work.

Could it be caused by the fact that I create user "fds" with group "fds", and use those for 389ds ? (based on instructions on some tutorials).

I guess I'll have to setup it once more to make it fail and see if I can find something from SElinux related logfiles..
Comment 7 Pasi Karkkainen 2010-11-14 09:20:34 EST

It seems that "could not reliably determine the server's fully qualified domain name" was a red herring..

With Selinux disabled 389ds works, but I still get that same text, see:

Are you ready to set up your servers? [yes]:
Creating directory server . . .
Your new DS instance 'fedora01' was successfully created.
Creating the configuration directory server . . .
Beginning Admin Server creation . . .
Creating Admin Server files and directories . . .
Updating adm.conf . . .
Updating admpw . . .
Registering admin server with the configuration directory server . . .
Updating adm.conf with information from configuration directory server . . .
Updating the configuration for the httpd engine . . .
Starting admin server . . .
output: httpd.worker: Could not reliably determine the server's fully qualified domain name, using fedora01.test.local for ServerName
The admin server was successfully started.
Admin server was successfully created, configured, and started.
Exiting . . .
Log file is '/tmp/setupQdA8Ye.log'


So the problem is NOT related to that DNS/hostname thing.

I'll try to get some SElinux errors captured when SElinux is enabled.
Comment 8 Pasi Karkkainen 2010-11-14 09:43:18 EST
Here we go:

Nov 14 16:42:05 fedora01 setroubleshoot: SELinux is preventing /usr/sbin/httpd.worker "read" access on hosts. For complete SELinux messages. run sealert -l 858c2345-a44f-413a-b9f9-219755a2e05d

Nov 14 16:42:05 fedora01 setroubleshoot: SELinux is preventing /usr/sbin/httpd.worker "read" access on hosts. For complete SELinux messages. run sealert -l 858c2345-a44f-413a-b9f9-219755a2e05d

Nov 14 16:42:05 fedora01 setroubleshoot: SELinux is preventing /usr/sbin/httpd.worker "read" access on hosts. For complete SELinux messages. run sealert -l 858c2345-a44f-413a-b9f9-219755a2e05d



Are you ready to set up your servers? [yes]:
Creating directory server . . .
Your new DS instance 'fedora01' was successfully created.
Creating the configuration directory server . . .
Beginning Admin Server creation . . .
Creating Admin Server files and directories . . .
Updating adm.conf . . .
Updating admpw . . .
Registering admin server with the configuration directory server . . .
Updating adm.conf with information from configuration directory server . . .
Updating the configuration for the httpd engine . . .
Starting admin server . . .
output: httpd.worker: apr_sockaddr_info_get() failed for fedora01.test.local
output: httpd.worker: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Could not start the admin server.  Error: 256
Failed to create and configure the admin server
Exiting . . .
Log file is '/tmp/setupz5oTV0.log'


# rpm -qa | grep 389
389-ds-base-1.2.6.1-2.fc14.x86_64
389-admin-console-1.1.5-1.fc14.noarch
389-admin-1.1.11-1.fc14.x86_64
389-admin-console-doc-1.1.5-1.fc14.noarch
389-console-1.1.4-1.fc14.noarch
389-dsgw-1.1.5-2.fc14.x86_64
389-ds-console-doc-1.2.3-1.fc14.noarch
389-ds-1.2.1-1.fc14.noarch
389-adminutil-1.1.10-2.fc14.x86_64
389-ds-console-1.2.3-1.fc14.noarch
Comment 9 Pasi Karkkainen 2010-11-14 09:48:13 EST
[root@fedora01 ~]# sealert -l 858c2345-a44f-413a-b9f9-219755a2e05d

Summary:

SELinux is preventing /usr/sbin/httpd.worker "read" access on hosts.

Detailed Description:

SELinux denied access requested by httpd.worker. It is not expected that this
access is required by httpd.worker and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:httpd_t:SystemLow-SystemHigh
Target Context                system_u:object_r:initrc_tmp_t:SystemLow
Target Objects                hosts [ file ]
Source                        httpd.worker
Source Path                   /usr/sbin/httpd.worker
Port                          <Unknown>
Host                          fedora01.test.local
Source RPM Packages           httpd-2.2.17-1.fc14
Target RPM Packages
Policy RPM                    selinux-policy-3.9.7-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     fedora01.test.local
Platform                      Linux fedora01.test.local 2.6.35.6-48.fc14.x86_64
                              #1 SMP Fri Oct 22 15:36:08 UTC 2010 x86_64 x86_64
Alert Count                   3
First Seen                    Sun Nov 14 16:42:02 2010
Last Seen                     Sun Nov 14 16:42:02 2010
Local ID                      858c2345-a44f-413a-b9f9-219755a2e05d
Line Numbers

Raw Audit Messages

node=fedora01.test.local type=AVC msg=audit(1289745722.711:50): avc:  denied  { read } for  pid=1837 comm="httpd.worker" name="hosts" dev=dm-0 ino=17115 scontext=system_u:system_r:httpd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file

node=fedora01.test.local type=SYSCALL msg=audit(1289745722.711:50): arch=c000003e syscall=2 success=no exit=-13 a0=7f78dd4b0390 a1=80000 a2=1b6 a3=0 items=0 ppid=1829 pid=1837 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=1 comm="httpd.worker" exe="/usr/sbin/httpd.worker" subj=system_u:system_r:httpd_t:s0-s0:c0.c1023 key=(null)
Comment 10 Rich Megginson 2010-11-15 11:27:30 EST
Nathan, do we need to fix this in the selinux policy?
Comment 11 Nathan Kinder 2010-11-15 11:33:18 EST
(In reply to comment #10)
> Nathan, do we need to fix this in the selinux policy?

I'm not sure if this is an issue with the dirsrv-admin policy needing to extend httpd, or if this is a shortcoming in the httpd policy.

Where is apr_sockaddr_info_get() being called from?  If it is from our code, we should fix it in our policy.  If it's from one of the Apache modules that is shipped as part of Fedora, it should be fixed in the system httpd policy.
Comment 13 Nathan Kinder 2010-11-30 14:33:21 EST
Moving this to the selinux-policy component.

I'm not sure what "hosts" file it is referring to.  I would not expect it to be /etc/hosts since the target label is initrc_tmp_t.

Can the reporter please check what the label is on /etc/hosts by running the following command:

  ls -lZ /etc/hosts
Comment 14 Daniel Walsh 2010-11-30 17:05:00 EST
restorecon -R -v /etc/hosts

Should fix, Does the install script create this file?  initrc_tmp_t is only create by initrc scripts creating files in /tmp.  If they created a file in /tmp and mv it to /etc/hosts, we could get this bad label.

Pasi, if SELinux is causing problems on  your machine, put it in permissive mode rather then into disabled, then we can easily diagnose what is wrong.
Comment 15 Pasi Karkkainen 2010-11-30 17:51:38 EST
Ok, I'll try it again (hopefully) tomorrow with SElinux enabled. I'll get back to you then!

Thanks!
Comment 16 Pasi Karkkainen 2010-12-03 03:23:57 EST
Hmm, Fedora 14 gives this:

yum install 389-ds openldap-clients

..

--> Processing Conflict: 389-admin-1.1.13-1.fc14.x86_64 conflicts selinux-policy-base < 3.9.8
--> Finished Dependency Resolution
Error: 389-admin conflicts with selinux-policy-targeted
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

but there's only 3.9.7* available on F14 .. (in updates-testing).
Comment 17 Rich Megginson 2010-12-03 09:08:15 EST
Unfortunately, the 389 packages that solve this problem are still in Testing, not in stable - so if you do

yum install --enablerepo=updates-testing 389-ds openldap-clients

You'll get the correct packages.
Comment 18 Pasi Karkkainen 2010-12-03 11:16:23 EST
Thanks, --enablerepo=updates-testing helped to install the rpms.

Are you ready to set up your servers? [yes]:
Creating directory server . . .
Your new DS instance 'fedora01' was successfully created.
Creating the configuration directory server . . .
Beginning Admin Server creation . . .
Creating Admin Server files and directories . . .
Updating adm.conf . . .
Updating admpw . . .
Registering admin server with the configuration directory server . . .
Updating adm.conf with information from configuration directory server . . .
Updating the configuration for the httpd engine . . .
Starting admin server . . .
Could not start the admin server.  Error: 256
Failed to create and configure the admin server
Exiting . . .
Log file is '/tmp/setupoY9Oqi.log'


[root@fedora01 ~]# ls -lZ /etc/hosts
-rw-r--r--. root root system_u:object_r:initrc_tmp_t:s0 /etc/hosts

[root@fedora01 ~]# getenforce
Enforcing


[root@fedora01 ~]# rpm -qa | grep 389
389-admin-1.1.13-2.fc14.x86_64
389-ds-console-1.2.3-1.fc14.noarch
389-admin-console-doc-1.1.5-1.fc14.noarch
389-console-1.1.4-1.fc14.noarch
389-adminutil-1.1.13-1.fc14.x86_64
389-ds-base-1.2.7.1-1.fc14.x86_64
389-dsgw-1.1.6-1.fc14.x86_64
389-admin-console-1.1.5-1.fc14.noarch
389-ds-console-doc-1.2.3-1.fc14.noarch
389-ds-1.2.1-1.fc14.noarch
Comment 19 Miroslav Grepl 2010-12-03 11:25:47 EST
Ok, put machine to permissive mode

# setenforce 0

Re-test and execute

# ausearch -m avc -ts recent

It gives us full AVC messages.

But it looks the file is created in /tmp and then move to /etc/hosts. How Dan mentioned in the comment #14.
Comment 20 Pasi Karkkainen 2010-12-03 11:47:32 EST
----
time->Fri Dec  3 18:37:18 2010
type=SYSCALL msg=audit(1291394238.153:494): arch=c000003e syscall=2 success=no exit=-13 a0=7f1562dba390 a1=80000 a2=1b6 a3=0 items=0 ppid=1151 pid=2265 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394238.153:494): avc:  denied  { read } for  pid=2265 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:37:18 2010
type=SYSCALL msg=audit(1291394238.154:495): arch=c000003e syscall=2 success=no exit=-13 a0=7f1562dba390 a1=80000 a2=1b6 a3=0 items=0 ppid=1151 pid=2265 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394238.154:495): avc:  denied  { read } for  pid=2265 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:37:18 2010
type=SYSCALL msg=audit(1291394238.158:496): arch=c000003e syscall=2 success=no exit=-13 a0=7f1562dba390 a1=80000 a2=1b6 a3=0 items=0 ppid=1151 pid=2265 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394238.158:496): avc:  denied  { read } for  pid=2265 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:39:41 2010
type=SYSCALL msg=audit(1291394381.311:501): arch=c000003e syscall=2 success=no exit=-13 a0=7f606ca2b390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1730 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=60 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394381.311:501): avc:  denied  { read } for  pid=1730 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:39:41 2010
type=SYSCALL msg=audit(1291394381.325:503): arch=c000003e syscall=2 success=no exit=-13 a0=7f606ca2b390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1730 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=60 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394381.325:503): avc:  denied  { read } for  pid=1730 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:21 2010
type=SYSCALL msg=audit(1291394421.777:5): arch=c000003e syscall=2 success=no exit=-13 a0=7f4a7cd05390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1189 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ntpd" exe="/usr/sbin/ntpd" subj=system_u:system_r:ntpd_t:s0 key=(null)
type=AVC msg=audit(1291394421.777:5): avc:  denied  { read } for  pid=1189 comm="ntpd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:ntpd_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:22 2010
type=SYSCALL msg=audit(1291394422.315:6): arch=c000003e syscall=2 success=no exit=-13 a0=7f4a7cd05390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1189 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ntpd" exe="/usr/sbin/ntpd" subj=system_u:system_r:ntpd_t:s0 key=(null)
type=AVC msg=audit(1291394422.315:6): avc:  denied  { read } for  pid=1189 comm="ntpd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:ntpd_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:22 2010
type=SYSCALL msg=audit(1291394422.319:7): arch=c000003e syscall=2 success=no exit=-13 a0=7f4a7cd05390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1189 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ntpd" exe="/usr/sbin/ntpd" subj=system_u:system_r:ntpd_t:s0 key=(null)
type=AVC msg=audit(1291394422.319:7): avc:  denied  { read } for  pid=1189 comm="ntpd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:ntpd_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:22 2010
type=SYSCALL msg=audit(1291394422.322:8): arch=c000003e syscall=2 success=no exit=-13 a0=7f4a7cd05390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1189 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ntpd" exe="/usr/sbin/ntpd" subj=system_u:system_r:ntpd_t:s0 key=(null)
type=AVC msg=audit(1291394422.322:8): avc:  denied  { read } for  pid=1189 comm="ntpd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:ntpd_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:22 2010
type=SYSCALL msg=audit(1291394422.325:9): arch=c000003e syscall=2 success=no exit=-13 a0=7f4a7cd05390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1189 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ntpd" exe="/usr/sbin/ntpd" subj=system_u:system_r:ntpd_t:s0 key=(null)
type=AVC msg=audit(1291394422.325:9): avc:  denied  { read } for  pid=1189 comm="ntpd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:ntpd_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:22 2010
type=SYSCALL msg=audit(1291394422.503:10): arch=c000003e syscall=2 success=no exit=-13 a0=7fb9dc643390 a1=80000 a2=1b6 a3=0 items=0 ppid=1194 pid=1201 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="postalias" exe="/usr/sbin/postalias" subj=system_u:system_r:postfix_master_t:s0 key=(null)
type=AVC msg=audit(1291394422.503:10): avc:  denied  { read } for  pid=1201 comm="postalias" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:postfix_master_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:22 2010
type=SYSCALL msg=audit(1291394422.688:11): arch=c000003e syscall=2 success=no exit=-13 a0=7f4a7cd05390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1189 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ntpd" exe="/usr/sbin/ntpd" subj=system_u:system_r:ntpd_t:s0 key=(null)
type=AVC msg=audit(1291394422.688:11): avc:  denied  { read } for  pid=1189 comm="ntpd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:ntpd_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:22 2010
type=SYSCALL msg=audit(1291394422.890:12): arch=c000003e syscall=2 success=no exit=-13 a0=7f4a7cd05390 a1=80000 a2=1b6 a3=0 items=0 ppid=1 pid=1189 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ntpd" exe="/usr/sbin/ntpd" subj=system_u:system_r:ntpd_t:s0 key=(null)
type=AVC msg=audit(1291394422.890:12): avc:  denied  { read } for  pid=1189 comm="ntpd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:ntpd_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:40:23 2010
type=SYSCALL msg=audit(1291394423.590:13): arch=c000003e syscall=2 success=no exit=-13 a0=7fc97565d390 a1=80000 a2=1b6 a3=0 items=0 ppid=1194 pid=1203 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="postfix" exe="/usr/sbin/postfix" subj=system_u:system_r:postfix_master_t:s0 key=(null)
type=AVC msg=audit(1291394423.590:13): avc:  denied  { read } for  pid=1203 comm="postfix" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:postfix_master_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:30 2010
type=SYSCALL msg=audit(1291394490.684:14): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394490.684:14): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:30 2010
type=SYSCALL msg=audit(1291394490.686:15): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394490.686:15): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:30 2010
type=SYSCALL msg=audit(1291394490.688:16): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394490.688:16): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:34 2010
type=SYSCALL msg=audit(1291394494.301:21): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394494.301:21): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:34 2010
type=SYSCALL msg=audit(1291394494.307:23): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394494.307:23): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:34 2010
type=SYSCALL msg=audit(1291394494.549:28): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394494.549:28): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:32 2010
type=SYSCALL msg=audit(1291394492.351:17): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394492.351:17): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:32 2010
type=SYSCALL msg=audit(1291394492.353:18): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394492.353:18): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:34 2010
type=SYSCALL msg=audit(1291394494.296:19): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1178 pid=1238 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394494.296:19): avc:  denied  { read } for  pid=1238 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:34 2010
type=SYSCALL msg=audit(1291394494.592:30): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1238 pid=1243 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=1 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394494.592:30): avc:  denied  { read } for  pid=1243 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:41:34 2010
type=SYSCALL msg=audit(1291394494.614:32): arch=c000003e syscall=2 success=no exit=-13 a0=7f2973dc1390 a1=80000 a2=1b6 a3=0 items=0 ppid=1238 pid=1243 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=1 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394494.614:32): avc:  denied  { read } for  pid=1243 comm="sshd" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:44:02 2010
type=SYSCALL msg=audit(1291394642.059:35): arch=c000003e syscall=2 success=yes exit=4 a0=7f62e34ed390 a1=80000 a2=1b6 a3=0 items=0 ppid=1461 pid=1463 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=1 comm="httpd.worker" exe="/usr/sbin/httpd.worker" subj=system_u:system_r:httpd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394642.059:35): avc:  denied  { open } for  pid=1463 comm="httpd.worker" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:httpd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
type=AVC msg=audit(1291394642.059:35): avc:  denied  { read } for  pid=1463 comm="httpd.worker" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:httpd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:44:02 2010
type=SYSCALL msg=audit(1291394642.059:36): arch=c000003e syscall=5 success=yes exit=0 a0=4 a1=7fff4ae97a70 a2=7fff4ae97a70 a3=0 items=0 ppid=1461 pid=1463 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=1 comm="httpd.worker" exe="/usr/sbin/httpd.worker" subj=system_u:system_r:httpd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394642.059:36): avc:  denied  { getattr } for  pid=1463 comm="httpd.worker" path="/etc/hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:httpd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:44:04 2010
type=SYSCALL msg=audit(1291394644.004:37): arch=c000003e syscall=2 success=yes exit=7 a0=7f62e34ed390 a1=80000 a2=1b6 a3=0 items=0 ppid=1464 pid=1466 auid=0 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="httpd.worker" exe="/usr/sbin/httpd.worker" subj=system_u:system_r:httpd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394644.004:37): avc:  denied  { open } for  pid=1466 comm="httpd.worker" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:httpd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
type=AVC msg=audit(1291394644.004:37): avc:  denied  { read } for  pid=1466 comm="httpd.worker" name="hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:httpd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
----
time->Fri Dec  3 18:44:04 2010
type=SYSCALL msg=audit(1291394644.004:38): arch=c000003e syscall=5 success=yes exit=0 a0=7 a1=7fff4ae97e50 a2=7fff4ae97e50 a3=0 items=0 ppid=1464 pid=1466 auid=0 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="httpd.worker" exe="/usr/sbin/httpd.worker" subj=system_u:system_r:httpd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1291394644.004:38): avc:  denied  { getattr } for  pid=1466 comm="httpd.worker" path="/etc/hosts" dev=dm-0 ino=17108 scontext=system_u:system_r:httpd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file
Comment 21 Daniel Walsh 2010-12-06 11:25:03 EST
restorecon /etc/hosts

Some init script is creating the /etc/hosts file with the wrong label.  Probably creating it in /tmp and mv'ing it to /etc
Comment 22 Pasi Karkkainen 2010-12-06 11:49:10 EST
Thanks. I'll try it.

This is actually a vmware VM, so it's probably the vmware-tools guest customization script..
Comment 23 Daniel Walsh 2010-12-06 14:34:22 EST
You should try kvm.  :^)
Comment 24 Nathan Kinder 2010-12-10 17:08:49 EST
Did fixing the label on /etc/hosts resolve this issue?
Comment 25 Pasi Karkkainen 2010-12-13 14:44:01 EST
Sorry for the delay.

[root@fedora01 ~]# ls -lZ /etc/hosts
-rw-r--r--. root root system_u:object_r:initrc_tmp_t:SystemLow /etc/hosts

[root@fedora01 ~]# restorecon /etc/hosts
[root@fedora01 ~]# ls -lZ /etc/hosts
-rw-r--r--. root root system_u:object_r:net_conf_t:SystemLow /etc/hosts
[root@fedora01 ~]#

[root@fedora01 ~]# getenforce
Enforcing

[root@fedora01 ~]# rpm -qa | grep 389
389-ds-base-1.2.7.4-1.fc14.x86_64
389-admin-console-1.1.5-1.fc14.noarch
389-dsgw-1.1.6-1.fc14.x86_64
389-admin-console-doc-1.1.5-1.fc14.noarch
389-ds-1.2.1-1.fc14.noarch
389-adminutil-1.1.13-1.fc14.x86_64
389-admin-1.1.13-2.fc14.x86_64
389-ds-console-1.2.3-1.fc14.noarch
389-ds-console-doc-1.2.3-1.fc14.noarch
389-console-1.1.4-1.fc14.noarch


..
Are you ready to set up your servers? [yes]:
Creating directory server . . .
Your new DS instance 'fedora01' was successfully created.
Creating the configuration directory server . . .
Beginning Admin Server creation . . .
Creating Admin Server files and directories . . .
Updating adm.conf . . .
Updating admpw . . .
Registering admin server with the configuration directory server . . .
Updating adm.conf with information from configuration directory server . . .
Updating the configuration for the httpd engine . . .
Starting admin server . . .
The admin server was successfully started.
Admin server was successfully created, configured, and started.
Exiting . . .
Log file is '/tmp/setupkORV8b.log'

So yes, "restorecon /etc/hosts" fixes the problem!
Thanks a lot!
Comment 26 Nathan Kinder 2010-12-13 15:17:21 EST
Glad to hear the relabel fixed your problem.  Closing this bug.
Comment 27 Daniel Walsh 2010-12-13 15:55:21 EST
But what caused /etc/hosts to be mislabeled in the first place?
Comment 28 Pasi Karkkainen 2010-12-13 16:21:42 EST
Daniel: It was caused by vmware-tools guest customization scripts..
Comment 29 Daniel Walsh 2010-12-14 09:11:25 EST
Ok, Can you report a bug to them.  They did similar hacking with /etc/services.
Comment 30 Vitalii Chepeliuk 2013-03-01 10:40:31 EST
I think relable cannot fix it! 
systemctl status dirsrv-admin.service 
dirsrv-admin.service - 389 Administration Server.
	  Loaded: loaded (/usr/lib/systemd/system/dirsrv-admin.service; enabled)
	  Active: failed (Result: exit-code) since Sat, 02 Mar 2013 01:31:29 +0100
	 Process: 1020 ExecStart=/usr/sbin/httpd.worker -k start -f /etc/dirsrv/admin-serv/httpd.conf (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/dirsrv-admin.service
Comment 31 Vitalii Chepeliuk 2013-03-01 10:43:38 EST
Forget yet log file intro
[13/03/01:15:24:23] - [Setup] Info Are you ready to set up your servers?
[13/03/01:15:24:25] - [Setup] Info yes
[13/03/01:15:24:25] - [Setup] Info Creating directory server . . .
[13/03/01:15:24:29] - [Setup] Info Your new DS instance 'ldap' was successfully created.
[13/03/01:15:24:29] - [Setup] Info Creating the configuration directory server . . .
[13/03/01:15:24:30] - [Setup] Info Beginning Admin Server reconfiguration . . .
[13/03/01:15:24:30] - [Setup] Info Creating Admin Server files and directories . . .
[13/03/01:15:24:30] - [Setup] Info Updating adm.conf . . .
[13/03/01:15:24:30] - [Setup] Info Updating admpw . . .
[13/03/01:15:24:30] - [Setup] Info Registering admin server with the configuration directory server . . .
[13/03/01:15:24:30] - [Setup] Info Updating adm.conf with information from configuration directory server . . .
[13/03/01:15:24:30] - [Setup] Info Updating the configuration for the httpd engine . . .
[13/03/01:15:24:30] - [Setup] Info Starting admin server . . .
[13/03/01:15:24:30] - [Setup] Info output: Job failed. See system journal and 'systemctl status' for details.
[13/03/01:15:24:30] - [Setup] Fatal Could not reconfigure the admin server.
[13/03/01:15:24:30] - [Setup] Fatal Exiting . . .
Comment 32 Noriko Hosoi 2013-03-01 13:42:48 EST
Hi, Vitalii Chepeliuk.

Could you provide us more info?
rpm -q 389-ds-base
rpm -q 389-admin

Are there any error reports in /var/log/messages, /var/log/dirsrv/admin/error, /var/log/dirsrv/slapd-YOURINST/errors?

If you restart the admin server, what do you see on the terminal and /var/log/dirsrv/admin/error?
systemctl restart dirsrv-admin.service
Comment 33 Vitalii Chepeliuk 2013-03-01 14:14:34 EST
I already uninstalled it and I removed all logs so could not provide you more info now. Just that dirsrv was listening on ipv6 but not ipv4
Comment 34 Noriko Hosoi 2013-03-01 14:28:26 EST
(In reply to comment #33)
> I already uninstalled it and I removed all logs so could not provide you
> more info now. Just that dirsrv was listening on ipv6 but not ipv4

So, the problem was worked around/solved?
Comment 35 Vitalii Chepeliuk 2013-03-01 14:32:19 EST
/var/log/messages
Mar  1 20:21:55 localhost yum[1873]: Installed: 389-adminutil-1.1.15-3.fc17.x86_64
Mar  1 20:21:55 localhost yum[1873]: Installed: svrcore-4.0.4-7.fc17.x86_64
Mar  1 20:21:56 localhost yum[1873]: Installed: jss-4.2.6-24.fc17.x86_64
Mar  1 20:21:56 localhost yum[1873]: Installed: ldapjdk-4.18-11.fc17.noarch
Mar  1 20:21:57 localhost yum[1873]: Installed: idm-console-framework-1.1.7-4.fc17.noarch
Mar  1 20:21:58 localhost yum[1873]: Installed: 389-console-1.1.7-2.fc17.noarch
Mar  1 20:21:58 localhost yum[1873]: Installed: 389-ds-base-libs-1.2.11.17-1.fc17.x86_64
Mar  1 20:21:59 localhost yum[1873]: Installed: httpd-tools-2.2.23-1.fc17.x86_64
Mar  1 20:22:00 localhost yum[1873]: Installed: perl-NetAddr-IP-4.058-2.fc17.x86_64
Mar  1 20:22:00 localhost yum[1873]: Installed: apr-util-ldap-1.4.1-2.fc17.x86_64
Mar  1 20:22:02 localhost systemd[1]: Reloading.
Mar  1 20:22:03 localhost yum[1873]: Installed: httpd-2.2.23-1.fc17.x86_64
Mar  1 20:22:04 localhost yum[1873]: Installed: mod_nss-1.0.8-17.fc17.x86_64
Mar  1 20:22:04 localhost yum[1873]: Installed: openldap-clients-2.4.33-3.fc17.x86_64
Mar  1 20:22:06 localhost systemd[1]: Reloading.
Mar  1 20:22:06 localhost yum[1873]: Installed: 389-ds-base-1.2.11.17-1.fc17.x86_64
Mar  1 20:22:07 localhost yum[1873]: Installed: 1:perl-FCGI-0.74-2.fc17.x86_64
Mar  1 20:22:07 localhost yum[1873]: Installed: perl-CGI-3.52-218.fc17.noarch
Mar  1 20:22:09 localhost systemd[1]: Reloading.
Mar  1 20:22:09 localhost yum[1873]: Installed: 389-admin-1.1.29-2.fc17.x86_64
Mar  1 20:22:09 localhost yum[1873]: Installed: 389-admin-console-1.1.8-3.fc17.noarch
Mar  1 20:22:10 localhost yum[1873]: Installed: 389-ds-console-1.2.6-2.fc17.noarch
Mar  1 20:22:11 localhost yum[1873]: Installed: 389-ds-console-doc-1.2.6-2.fc17.noarch
Mar  1 20:22:12 localhost yum[1873]: Installed: 389-admin-console-doc-1.1.8-3.fc17.noarch
Mar  1 20:22:13 localhost yum[1873]: Installed: 389-dsgw-1.1.9-3.fc17.x86_64
Mar  1 20:22:14 localhost yum[1873]: Installed: 389-ds-1.2.2-2.fc17.noarch
Mar  1 20:22:14 localhost dbus-daemon[621]: dbus[621]: [system] Activating service name='org.freedesktop.PackageKit' (using servicehelper)
Mar  1 20:22:14 localhost dbus[621]: [system] Activating service name='org.freedesktop.PackageKit' (using servicehelper)
Mar  1 20:22:14 localhost dbus-daemon[621]: dbus[621]: [system] Successfully activated service 'org.freedesktop.PackageKit'
Mar  1 20:22:14 localhost dbus[621]: [system] Successfully activated service 'org.freedesktop.PackageKit'
Mar  1 20:23:01 localhost dbus-daemon[621]: dbus[621]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Mar  1 20:23:01 localhost dbus[621]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Mar  1 20:23:01 localhost dbus-daemon[621]: Launching FprintObject
Mar  1 20:23:01 localhost dbus-daemon[621]: dbus[621]: [system] Successfully activated service 'net.reactivated.Fprint'
Mar  1 20:23:01 localhost dbus[621]: [system] Successfully activated service 'net.reactivated.Fprint'
Mar  1 20:23:01 localhost dbus-daemon[621]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Mar  1 20:23:01 localhost dbus-daemon[621]: ** Message: entering main loop
Mar  1 20:23:03 localhost systemd-tmpfiles[2096]: stat(/run/user/chepa/gvfs) failed: Permission denied
Mar  1 20:23:31 localhost dbus-daemon[621]: ** Message: No devices in use, exit
Mar  1 20:23:34 localhost dbus-daemon[621]: dbus[621]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Mar  1 20:23:34 localhost dbus[621]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Mar  1 20:23:34 localhost dbus-daemon[621]: Launching FprintObject
Mar  1 20:23:34 localhost dbus-daemon[621]: dbus[621]: [system] Successfully activated service 'net.reactivated.Fprint'
Mar  1 20:23:34 localhost dbus[621]: [system] Successfully activated service 'net.reactivated.Fprint'
Mar  1 20:23:34 localhost dbus-daemon[621]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Mar  1 20:23:34 localhost dbus-daemon[621]: ** Message: entering main loop
Mar  1 20:24:05 localhost dbus-daemon[621]: ** Message: No devices in use, exit
Mar  1 20:24:21 localhost systemd[1]: Reloading.

/var/log/dirsrv/admin doesnt exist, dirsrv-admin was not started!
/var/log/dirsrv/slapd-ldap/errors does not exist
[root@localhost ~]# systemctl restart dirsrv-admin.service
Job failed. See system journal and 'systemctl status' for details.
 
[root@localhost ~]# systemctl status dirsrv-admin.service
dirsrv-admin.service - 389 Administration Server.
          Loaded: loaded (/usr/lib/systemd/system/dirsrv-admin.service; enabled)
          Active: failed (Result: exit-code) since Fri, 01 Mar 2013 20:30:52 +0100; 28s ago
         Process: 2623 ExecStart=/usr/sbin/httpd.worker -k start -f /etc/dirsrv/admin-serv/httpd.conf (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/dirsrv-admin.service

Mar 01 20:30:52 localhost.localdomain httpd.worker[2623]: httpd.worker: Could not reliably determine the server's full...Name
Mar 01 20:30:52 localhost.localdomain httpd.worker[2623]: (13)Permission denied: make_sock: could not bind to address ...9830
Mar 01 20:30:52 localhost.localdomain httpd.worker[2623]: no listening sockets available, shutting down
Mar 01 20:30:52 localhost.localdomain httpd.worker[2623]: Unable to open logs
and after restart still no admin/error exists!
Comment 36 Vitalii Chepeliuk 2013-03-01 14:35:51 EST
Sorry forget 
[root@localhost ~]# rpm -q 389-ds-base
389-ds-base-1.2.11.17-1.fc17.x86_64
[root@localhost ~]# rpm -q 389-admin
389-admin-1.1.29-2.fc17.x86_64
Problem was not solved, still does not work for me, I was trying to setup it one week and no result
[root@localhost ~]# lsof -i:389
COMMAND   PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
ns-slapd 2459 ldap    6u  IPv6  23596      0t0  TCP *:ldap (LISTEN)
And this is my last report I think It will help you to find issue, cause I am now removing Fedora at all))

Note You need to log in before you can comment on or make changes to this bug.