Bug 64986 - auth --enablemd5 --enableshadow has no effect
auth --enablemd5 --enableshadow has no effect
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-15 13:45 EDT by Mike Snitzer
Modified: 2007-03-26 23:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 14:40:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Snitzer 2002-05-15 13:45:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.7smp i686; Nav)

Description of problem:
if I use: auth --enablemd5 --useshadow in a 7.2 or 7.3 kickstart the system does
NOT use shadow passwords until I run pwconv

I realize there are different commands that should bring about the same
result via kickstart (but non are working), i.e.:

authconfig --enableshadow --enablemd5
auth --enableshadow --enablemd5
auth --enablemd5 --useshadow

In looking at the anaconda source all translate to the same variables being
set properly; so these _should_ just work... but like I said they aren't.

The password file just contains crypted passwords (NOT shadowed)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add auth --enablemd5 --enableshadow to a ks.cfg
2. kickstart an install
3. after finishing /etc/passwd only contains encrypted NON-shadowed passwords
	

Actual Results:  /etc/passwd contains encrypted NON-shadowed passwords; which is
the "default" for anaconda.

Expected Results:  the passwords _should_ be shadowed

Additional info:

I've hacked around this by running /usr/sbin/pwconv in %post; but this is ugly
and shouldn't be needed..... I don't have time to track this down myself.. maybe
if it continues to go unfixed I'll be forced to
Comment 1 Alex Yacoub 2002-06-17 14:48:30 EDT
I ran into this problem myself and tracked it down: if you remove the authconfig
package from the install (by writing -authconfig in the %packages section), then
shadowed passwords won't be enabled.  The workaround, of course, is to let
authconfig install.  If you don't want it, you can uninstall it in the %post
section.

This discovery means that anaconda depends on outside packages to do some of
it's work.  Can RedHat provide a list of those specific packages needed (many of
us feel the base system is a little large and cut it down accordingly, and I
don't want to cut anything else out that's important).  Personally, I think all
the tools that anaconda uses for setup need to be self contained as a part of
anaconda, or, at the very least, contained in an install package on the CD or
installation media in a way that doesn't require anything installed on the
actual computer.  Dependencies on installed software should be considered as
bugs, at least for any actions that can be done from kickstart.

-Alex
Comment 2 Michael Fulbright 2002-08-21 12:41:30 EDT
The base component has everything required by anaconda.  You should build from it.
Comment 3 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.