Bug 650184 - RFE: entitlement handling when systems are registered across different organizations
RFE: entitlement handling when systems are registered across different organi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: New Feature (Show other bugs)
unspecified
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: Todd Warner
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-05 09:55 EDT by Thorsten Scherf
Modified: 2010-11-16 15:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-16 15:20:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
satellite with two orgs, where hypervisors are registered in org A and virtual machines in org B (17.90 KB, image/png)
2010-11-05 09:56 EDT, Thorsten Scherf
no flags Details

  None (edit)
Description Thorsten Scherf 2010-11-05 09:55:02 EDT
Description of problem:
Virtual machines registered on a Satellite server usually don't consume their own entitlements. That's true up to 4 guests in case of host is using regular RHEL and unlimited when host is using AP. A problem comes up, when you have different satellite organizations available. See attached picture. Hosts are registered in Org A and virtual machines in Org B. This is a common setup. Usually you want to have a separation of management systems (hypervisors) and workload systems (virtual machines) since different people/departments are responsible for those systems. 

The problem now is, when the hosts are not available in the same org where the virtual systems have been registered, every virtual system is consuming an entitlements. This results in additional entitlements that have been bought by a customer.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.setup two satellite orgs
2.register one hypervisor (rhev-h or rhel) into org A 
3.in org B, register a virtual machine running on the hypervisor that has been registered in org A  
  
Actual results:
virtual machine is consuming an entitlement. 

Expected results:
virtual machine is _not_ consuming an entitlement and inherits the one from the host where it runs on. 

Additional info:
Comment 1 Thorsten Scherf 2010-11-05 09:56:39 EDT
Created attachment 458087 [details]
satellite with two orgs, where hypervisors are registered in org A and virtual machines in org B
Comment 2 Thorsten Scherf 2010-11-15 05:01:44 EST
note to myself: looks like this feature is available in RHNS-5.4
Comment 3 Clifford Perry 2010-11-16 15:20:53 EST
This is in Sat 5.4.0 as a listed feature/capability. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.