Bug 65027 - dvips gcc.dvi fails for gcc 3.1
Summary: dvips gcc.dvi fails for gcc 3.1
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-16 10:32 UTC by John Gotts
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-26 13:00:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Gotts 2002-05-16 10:32:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
There is something wrong with tetex as distributed with Red Hat 7.3.  It fails
to generate gcc.ps, while Red Hat 7.2 has no problems with this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ./configure from the gcc 3.1 toplevel directory
2. make dvi
3. cd gcc && dvips gcc.dvi
	

Actual Results:  This is dvips(k) 5.86 Copyright 1999 Radical Eye Software
(www.radicaleye.com)
' TeX output 2002.05.16:0610' -> |\
<texc.pro>Broken pipe


Expected Results:  This is from Red Hat 7.2:

This is dvips(k) 5.86 Copyright 1999 Radical Eye Software (www.radicaleye.com)
' TeX output 2002.05.16:0610' -> gcc.ps
<texc.pro>. [1] [2] [-1] [-2] [-3] [-4] [-5] [-6] [-7] [-8] ...

Additional info:

Comment 1 Tim Waugh 2002-05-24 11:06:29 UTC
I can't seem to get it to fail.  Does 'dvips -o gcc.ps gcc.dvi' work for you?

Comment 2 John Gotts 2002-05-25 18:56:33 UTC
Yes, that does work for me.

So it appears we have a default behavior change between 7.2 and 7.3.

Comment 3 Tim Waugh 2002-05-26 09:27:44 UTC
But 'dvips gcc.dvi' works for me too. 
 
Can you print at all?

Comment 4 John Gotts 2002-05-26 13:00:25 UTC
No, the printing system is not configured on either of these machines (7.2 or 7.3).

Comment 5 Tim Waugh 2002-05-27 07:40:16 UTC
Without -o, dvips will try to send the document to the printer.

Comment 6 John Gotts 2002-05-27 17:13:47 UTC
Why was the default behavior changed between 7.2 and 7.3?

Comment 7 Tim Waugh 2002-05-27 21:47:07 UTC
In Red Hat Linux 7.2, dvips had the same behaviour. (It has done as far back 
as I remember.)

Comment 8 John Gotts 2002-05-27 23:48:20 UTC
Then why does dvips gcc.dvi fail on 7.3 but not on 7.2?

Comment 9 Tim Waugh 2002-05-28 08:22:30 UTC
Using dvips without specifying an output file with -o sends the output to lpr; 
Red Hat Linux 7.2 is no different to Red Hat Linux 7.3 in this behaviour.  
When printing is not set up, this fails. 
 
Use -o.


Note You need to log in before you can comment on or make changes to this bug.