Bug 650639 - [RFE] Ability to enable plugins via abrt gui
[RFE] Ability to enable plugins via abrt gui
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.3
All Linux
low Severity medium
: rc
: ---
Assigned To: abrt
qe-baseos-tools
: FutureFeature
Depends On: 650975 697494
Blocks: 645519
  Show dependency treegraph
 
Reported: 2010-11-07 09:53 EST by James G. Brown III
Modified: 2014-12-01 18:07 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 04:55:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James G. Brown III 2010-11-07 09:53:07 EST
Description of problem:

abrt should provide a facility in the gui to enable plugins. You can configure them, but not enable them to run on a crash.

Actual results:

To enable the Bugzilla plugin you have to manually edit the abrt.conf

Expected results:

You can enable Bugzilla plugin (or any plugin) through the abrt gui
Comment 2 James G. Brown III 2010-11-07 10:21:36 EST
I would consider this a bug presuming that configuring the Bugzilla plugin also sets the expectation that it also be enabled. 

- James
Comment 3 Jiri Moskovcak 2011-01-04 09:34:52 EST
This would require a lot of code changes, so it's not a good candidate for 6.1
Comment 6 Denys Vlasenko 2011-08-24 04:20:06 EDT
(In reply to comment #0)
> abrt should provide a facility in the gui to enable plugins. You can configure
> them, but not enable them to run on a crash.
> 
> Actual results:
> 
> To enable the Bugzilla plugin you have to manually edit the abrt.conf
> 
> Expected results:
> 
> You can enable Bugzilla plugin (or any plugin) through the abrt gui

The configuration mechanism in ABRT 2.x is generic, meaning that there are very many ways to, say, configure reporting to Bugzilla: it can be configured to run at crash time or only when user requests it; it can be configured to run as part of a composite reporting event; it can be run with different options.

(See https://fedorahosted.org/abrt/wiki/AbrtDeployment2 section "Configuring ABRT" for a more detailed description)

The gist of it is that adding/removing Bugzilla reporting is far from being as simple as toggling a "yes/no" checkbox in gui.

I don't see how we can implement that.

Does anyone have a proposal how this can be implemented? Otherwise I propose to close it as WONTFIX.
Comment 7 Nikola Pajkovsky 2011-08-24 08:30:52 EDT
Yes, that could be another huge program and I tend to close it as WONTFIX
Comment 8 James G. Brown III 2011-08-24 08:41:57 EDT
If the intent is to have abrt make it easy for people to report bugs having them go into modify a configuration file is counter-intuitive for the typical desktop user.
Comment 9 Jiri Moskovcak 2011-09-08 08:38:06 EDT
This actually means to write something like system-config-abrt tool which will take a lot of coding and definitely won't happen in 6.2 -> resetting the flags.
Comment 15 RHEL Product and Program Management 2012-05-03 00:40:28 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 17 RHEL Product and Program Management 2012-08-15 04:55:11 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.