Bug 65088 - "@PJL SET ..." lines on first page of printouts
"@PJL SET ..." lines on first page of printouts
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-17 03:21 EDT by George Herson
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-17 23:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Herson 2002-05-17 03:21:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
Four lines, 
"@PJL SET MANUALFEED=OFF 
                        @PJL SET MEDIATYPE=NORMAL
                                                 @PJL SET PRINTQUALITY=NORMAL 
                   @PJL" appear as the first page for all my non-plain text
printouts. (Plain text prints fine.)

This problem did not occur under RedHat 7.1's printtool.  This problem occured
as soon as i upgraded to RedHat 7.2 and printconf and choose my correct printer
driver from the printconf menu.  (Before that, the default driver always
resulted in 0 pages being printed.)

My printer: A local HP LaserJet 1100, attached via parallel port.

My printconf settings are below.

Thx for your help.

Version-Release number of selected component (if applicable):
printconf-gui 0.3.44

How reproducible:
Always

Steps to Reproduce:
1. lpr /usr/doc/bind-8.2.2_P7/misc/domain.ps

	

Actual Results:  "@PJL SET MANUALFEED=OFF 
                        @PJL SET MEDIATYPE=NORMAL
                                                 @PJL SET PRINTQUALITY=NORMAL 
                   @PJL" appeared as the first page.  An otherwise successful
print followed.

Expected Results:  That first page of "@PJL SET ..." codes should not have
appeared, just the pages following it.

Additional info:
The output from # /usr/sbin/printconf-tui --Xexport:

<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="1021617662">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        <lp ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <queue_data TYPE="LIST">
            <local_printer_device TYPE="STRING" VALUE="/dev/lp0"/>
            </queue_data>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <filter_data TYPE="LIST">
            <flags TYPE="LIST">
              <send_EOT TYPE="BOOL" VALUE="FALSE"/>
              <assume_data_is_text TYPE="BOOL" VALUE="FALSE"/>
              <send_FF TYPE="BOOL" VALUE="FALSE"/>
              <rerender_Postscript TYPE="BOOL" VALUE="FALSE"/>
              <convert_text_to_Postscript TYPE="BOOL" VALUE="FALSE"/>
              </flags>
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <filter_locale TYPE="STRING" VALUE="C"/>
            <printer_id TYPE="STRING" VALUE="62816"/>
            <gs_driver TYPE="STRING" VALUE="ljet4"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              </foomatic_defaults>
            </filter_data>
          </lp>
        </print_queues>
      </printconf>
    </datatree>
  </adm_context>
Comment 1 Tim Waugh 2002-05-17 03:28:50 EDT
Apply the updates. 

*** This bug has been marked as a duplicate of 60343 ***
Comment 2 George Herson 2002-05-17 20:30:06 EDT
Unfortunately, I already had the suggested change:  From line 629 (of 669) of my
/usr/sbin/lpdomatic:

            if ( @pjlprepend > 1 ) {
                print $fileh @pjlprepend;
            }
            while (<KID4_IN>) {
                print $fileh $_;
            }
            if ( @pjlprepend > 1 ) {
                print $fileh @pjlappend;
            }

Where's rawhide? I searched redhat.com for it w/o finding.  

I'm trying # rpmfind printconf 
but the d/l speed on rehat's end means its going to take hrs unfortunately
(right now its d/l'ing Omni-0.5.1-3.i386.rpm).
Comment 3 George Herson 2002-05-17 23:11:07 EDT
I could not upgrade my printconf. 

(My installed printconf is 0.3.44.  Searching at
http://www.redhat.com/apps/download/ offers only printconf 0.2.15 - 2. 
Rpmfind.net and rpmfind also didn't work (extremely slow downloads that wouldn't
--verify).)
Comment 5 George Herson 2002-05-18 11:13:26 EDT
Issue unresolved for this noncustomer.

The upgrades proposed (http://rhn.redhat.com/errata/RHBA-2001-174.html) require
the >12MB Omni package and others which i can't seem to get downloaded completely.

Deleting mention of "pjl" from the .xml file, as someone mentioned, didn't have
any effect. 

Bug 42663 is related and specific to my printer model but i "do not have the
permissions necessary" to view it.
Comment 6 George Herson 2002-08-05 22:20:56 EDT
What do i need to do to be able to see <a
href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=42663">Bug 42663</a>?
 Buy a subscription?  What kind/level? 

Logging in as myself (gherson@snet.net) doesn't allow me to see this bug: "you
do not have the permissions necessary".

My print jobs still fail after a small number of pages.

Thank you.
Comment 7 Tim Waugh 2002-08-06 03:46:44 EDT
Do you now have all of the updates applied? (If not, apply them!)
Comment 8 George Herson 2002-08-06 10:05:35 EDT
I believe so: princonf and its gui: 0.3.77-1.  And foomatic-1.1-0.20020313.3,
Omni-foomatic-0.5.1-3, Omni Omni-0.5.1-3.  Are these recent enough?  (I ask in
part because it takes hours for me to run RHUpdate.)  Thank you.
Comment 9 Tim Waugh 2002-08-07 11:29:56 EDT
Use up2date.
Comment 10 George Herson 2002-08-07 14:16:52 EDT
I ran up2date (RH Update) and I had it install the only two rpms that had an
update that seemed possibly relevant: LPRng and groff.  I don't think it helped.
 For example, on the 6th page of
http://www-sop.inria.fr/lemme/Venanzio.Capretta/publications/general_recursion.pdf,
printing stops, with the formfeed light on my LJ1100 still on.  And at the same
time, if it's helpful:

# lpq  # This command shows:
Printer: lp0@dev-dell1
 Queue: 1 printable job
 Server: pid 6924 active
 Unspooler: pid 6925 active
 Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at 14:05:57.153
 Rank   Owner/ID                  Class Job Files                 Size Time
1      gherson@dev-dell1+923        A   923 /tmp/Acro19TzaD     292767 14:05:02
Comment 11 George Herson 2002-08-07 15:22:50 EDT
Update: Two seconds after I submitted the above comment, the page (p6) printed,
after >5min of waiting (extremely unusual).  So printing may now be working
after all, i don't really know.  I'm printing more things now.  If printing is
still bad i will let you know.
Comment 12 George Herson 2002-08-24 16:36:19 EDT
Unfortunately the problem is reoccuring and is not reproducible.  It frequently
occurs when I've sent multiple items or a long document to the printer. Here's
what lpq returns when the queue is stuck:

$ lpq
Printer: lp0@dev-dell1
 Queue: 2 printable jobs
 Server: pid 9006 active
 Unspooler: pid 9219 active
 Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at 16:27:10.890
 Rank   Owner/ID                  Class Job Files                 Size Time
1      gherson@dev-dell1+187        A   187 /tmp/AcroiBI2X0     271819 16:26:13
2      gherson@dev-dell1+228        A   228 /tmp/AcroytvXyB     271819 16:27:05

Not surprisingly, the lights on the printer are indicating that "The printer
memory is retaining unprinted data" according to my printer manual.  If I press
and release the Go button as it recommends, I always get a half-printed page and
a still-constipated printer that needs me to lprm the latest job before it can
continue.  

Also strange is that it can take 20min to print one (normal, textual) page, as I
think is shown by the output from these two $ lpq commands:
$ lpq
Printer: lp0@dev-dell1
 Queue: 2 printable jobs
 Server: pid 8590 active
 Unspooler: pid 8591 active
 Status: waiting for subserver to exit at 14:40:21.331
 Rank   Owner/ID                  Class Job Files                 Size Time
1      gherson@dev-dell1+589        A   589 (STDIN)             148322 14:39:41
2      gherson@dev-dell1+616        A   616 (STDIN)             171848 14:40:21

$ lpq
Printer: lp0@dev-dell1
 Queue: 2 printable jobs
 Server: pid 8590 active
 Unspooler: pid 8591 active
 Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at 15:02:16.190
 Rank   Owner/ID                  Class Job Files                 Size Time
1      gherson@dev-dell1+589        A   589 (STDIN)             148322 14:39:41
2      gherson@dev-dell1+616        A   616 (STDIN)             171848 14:40:21

Suggestions? thank you.

Note You need to log in before you can comment on or make changes to this bug.