This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 651091 - ppc64: rpm prefers 32bit binaries in multilib pkgs
ppc64: rpm prefers 32bit binaries in multilib pkgs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Martin Banas
:
: 701605 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-08 14:44 EST by Miroslav Vadkerti
Modified: 2011-05-19 08:52 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-13.21.84-1
Doc Type: Bug Fix
Doc Text:
anaconda in Red Hat Enterprise Linux 6 for Power writes an incorrect value to /etc/rpm/macros that can cause issues when installing 32 and 64-bit PowerPC packages together. Users are advised to remove this file after installation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 08:52:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 68223 None None None Never

  None (edit)
Description Miroslav Vadkerti 2010-11-08 14:44:03 EST
Description of problem:
# rpm -q openssl
openssl-1.0.0-4.el6_0.1.ppc
openssl-1.0.0-4.el6_0.1.ppc64
# file /usr/bin/openssl 
/usr/bin/openssl: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, with unknown capability 0x41000000 = 0x13676e75, with unknown capability 0x10000 = 0xb0401, stripped

In RHEL6 the preferred version should by the 64b ELF as on other multilib archs 

Version-Release number of selected component (if applicable):
rpm-4.8.0-12.el6

How reproducible:
100%

Steps to Reproduce:
see desc
  
Actual results:
32b elf preferred

Expected results:
64b elf preffered


Additional info:
Comment 1 Bill Nottingham 2010-11-08 14:55:41 EST
This is due to anaconda writing /etc/rpm/macros on ppc64 with _prefer_color=1.
Comment 2 Bill Nottingham 2010-11-08 14:55:41 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
anaconda in Red Hat Enterprise Linux 6 for Power writes an incorrect value to /etc/rpm/macros that can cause issues when installing 32 and 64-bit PowerPC packages together. Users are advised to remove this file after installation.
Comment 4 Chris Lumens 2010-11-12 10:04:54 EST
This is fixed by ba9df81a15eedcfae49c8332d30f53cfa27e2288.
Comment 5 RHEL Product and Program Management 2010-11-12 10:19:48 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 9 Martin Banas 2011-03-29 09:15:11 EDT
rpm -qa --queryformat="%{NAME}\n"| sort | uniq -c | awk '$1>1 { print $2 }' | while read i ; do rpm -ql $i | egrep '(s?bin)|(libexec)' ; done | while read file ; do test -x $file && echo $file ; done | sort -u | while read file ; do file $file | grep -q 32-bit && echo $file ; done
/usr/bin/gdk-pixbuf-query-loaders-32
/usr/bin/gtk-query-immodules-2.0-32
/usr/bin/pango-querymodules-32
/usr/libexec/getconf/POSIX_V6_ILP32_OFF32
/usr/libexec/getconf/POSIX_V6_ILP32_OFFBIG
/usr/libexec/getconf/POSIX_V7_ILP32_OFF32
/usr/libexec/getconf/POSIX_V7_ILP32_OFFBIG
/usr/sbin/glibc_post_upgrade.ppc
/usr/sbin/iconvconfig.ppc


All of them above have their 64 binaries, so it seems it's OK.
Retested on RHEL6.1-20110317.1 @Everything package set, moving the bug to VERIFIED.
Comment 10 John W. Lockhart 2011-05-03 11:41:11 EDT
*** Bug 701605 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2011-05-19 08:52:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html
Comment 12 errata-xmlrpc 2011-05-19 08:52:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html

Note You need to log in before you can comment on or make changes to this bug.