Bug 65110 - DRM modules were not built for i386 kernel
DRM modules were not built for i386 kernel
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-17 13:51 EDT by Tom "spot" Callaway
Modified: 2007-04-18 12:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 15:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2002-05-17 13:51:55 EDT
Description of Problem:

DRM modules were not built for i386 kernel

Version-Release number of selected component (if applicable):

2.4.18-3 & 2.4.18-4

How Reproducible:

Always

Steps to Reproduce:
1. Look for the DRM modules...
2. OOPS!

Actual Results:

No DRM modules.

Expected Results:

DRM modules.

Additional Information:
	
This is pretty sad. We need to enable CONFIG_DRM=y in
kernel-2.4.18-*.i386.config (and take it off the same line as CONFIG_DRM_OLD).
How this got out the door without being noticed is beyond me.
Comment 1 Arjan van de Ven 2002-05-20 08:28:28 EDT
The 80386 kernel doesn't have DRM on purpose;
DRM needs a newer CPU.
Comment 2 Chris Ricker 2002-06-03 01:07:04 EDT
I'm reopening this b/c it does seem to be a bug.

The problem is, the i386 kernel is what gets installed on machines which DO
support DRM but are not i686 / athlon.  For example, when I install Red Hat
Linux on an AMD K6-2, which is AFAIK capable of DRM, I get the i386 kernel and
so I don't get the DRM modules.
Comment 3 Chris Ricker 2002-06-03 01:12:06 EDT
Furthermore, the Provides statements for the i386 kernel are currently wrong,
since it doesn't provide DRM (either 4.1 or 4.2 versions).

[kaboom@skuld kaboom]$ rpm -q kernel --qf "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"
kernel-2.4.18-4.i386
[kaboom@skuld kaboom]$ rpm -q --provides kernel
module-info  
kernel = 2.4.18
kernel-drm = 4.1.0
kernel-drm = 4.2.0
kernel = 2.4.18-4
[kaboom@skuld kaboom]$ 
Comment 4 Gregory S. Hayes 2002-06-03 02:11:35 EDT
I have an AMD k6 450 and have had DRI working in the past. It seems like the
i386  build should include it... or there should be a i586 up kernel with it
compiled.
Comment 5 Gregory S. Hayes 2002-06-03 02:50:21 EDT
possible solution:

remove kernel-drm from the kernel-2.4.18-[4|3].i386.rpm provides. and create a
seperate kernel-drm package for i386.
Comment 6 Mike A. Harris 2002-06-03 03:01:00 EDT
All problems reported above IMHO are perfectly valid, and I definitely wanted
and tried to get them addressed for the final release.  I do not remember
what the reasons were, but users using non i686 machines were expected
to run the i586smp kernel to get DRM support.  Since it doesn't automatically
do that for all machines that are DRI capable, I consider that a flaw.

We should have an i586 UP kernel, and should support DRM on it, and use that
kernel for machines it will run on.

The other problem reported above, about the i386 kernel saying it supports
kernel-drm = xxxx  is a much larger problem.  The kernel is saying it reports
DRM, but it actually does not.  XFree86 *requires* kernel-drm in order to
install.  So, the result is, if the kernel that does not have DRM ends up
getting that line removed so it does not explicitly Provide kernel-drm, then
the dependancy wont be met, and XFree86 wont install.

I'm not sure how to properly handle that situation, but for now at least,
we MUST have kernel-drm provided by all kernels even if they don't contain
DRM.

Also, IMHO, the i386 kernel should have DRM modules also, since many users
are forced to use the i386 kernel for other reasons.  Those users end up
losing DRM in the process.

Another way of fixing it all, is to only ship i686 and Athlon kernels.

*runs*
Comment 7 Tom "spot" Callaway 2002-06-04 12:53:41 EDT
Or, we could just build i586 UP kernel rpms again.
Comment 8 Chris Ricker 2002-06-04 13:05:18 EDT
building i586 UP seems the sanest thing to do, now that the release is 3 CDs and
there's free space on the 3rd disc....
Comment 9 Tim Keitt 2002-11-04 14:05:22 EST
Well, I just installed the latest i686 kernel from the 8.0 errata and IT doesn't
have drm modules. -- T.
Comment 10 Arjan van de Ven 2002-11-04 14:06:53 EST
tkeitt@mail.utexas.edu:

yes it does

Note You need to log in before you can comment on or make changes to this bug.