Bug 65149 - Highpoint proc info segfaults when using cat
Highpoint proc info segfaults when using cat
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-18 10:48 EDT by Daniel Powell
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-08 12:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Powell 2002-05-18 10:48:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
cat /proc/ide/hpt366 segfaults and returns a kernel dump

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cat /proc/ide/hpt366
2. dmesg to see dump
3.
	

Actual Results:  cat /proc/ide/hpt366 
Segmentation fault

Expected Results:  Should return current info about the IDE controller

Additional info:

Unable to handle kernel NULL pointer dereference at virtual address 000000d0
 printing eip:
c019ba15
*pde = 00000000
Oops: 0000
autofs natsemi reiserfs usb-uhci usbcore ext3 jbd aic7xxx sd_mod scsi_mod  
CPU:    0
EIP:    0010:[<c019ba15>]    Not tainted
EFLAGS: 00010282

EIP is at hpt366_get_info [kernel] 0x15 (2.4.18-3)
eax: 00000000   ebx: 00000000   ecx: c7f2cca0   edx: 00000000
esi: 00000400   edi: c54af000   ebp: c54af000   esp: c1e25ef4
ds: 0018   es: 0018   ss: 0018
Process cat (pid: 2417, stackpage=c1e25000)
Stack: 00000000 c02c473c c02c48f8 00000003 00000001 c0131d2c 00000000 c02c4900 
       00000000 00000201 c0131e0a c02c48f4 00000000 00000003 00000001 00000000 
       00000001 00000000 00000400 00000400 c0157555 c54af000 c1e25f68 00000000 
Call Trace: [<c0131d2c>] __alloc_pages_limit [kernel] 0x7c 
[<c0131e0a>] __alloc_pages [kernel] 0xaa 
[<c0157555>] proc_file_read [kernel] 0xa5 
[<c0138de6>] sys_read [kernel] 0x96 
[<c0108923>] system_call [kernel] 0x33 


Code: 8b b0 d0 00 00 00 8d 44 24 20 8b 9a d0 00 00 00 c7 44 24 24
Comment 1 Arjan van de Ven 2002-05-21 05:22:10 EDT
do you happen to have a hpt372 or 374 controller? 
if so I think I just fixed this
Comment 2 Daniel Powell 2002-05-22 10:45:49 EDT
THis is a Highpoint HPT366

lspci -v -v 

00:13.0 Unknown mass storage controller: Triones Technologies, Inc. HPT366 / 
HPT370 (rev 01)
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 120 (2000ns min, 2000ns max), cache line size 08
        Interrupt: pin A routed to IRQ 18
        Region 0: I/O ports at cc00 [size=8]
        Region 1: I/O ports at d000 [size=4]
        Region 4: I/O ports at d400 [size=256]
        Expansion ROM at <unassigned> [disabled] [size=128K]

00:13.1 Unknown mass storage controller: Triones Technologies, Inc. HPT366 / 
HPT370 (rev 01)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 120 (2000ns min, 2000ns max), cache line size 08
        Interrupt: pin B routed to IRQ 18
        Region 0: I/O ports at d800 [size=8]
        Region 1: I/O ports at dc00 [size=4]
        Region 4: I/O ports at e000 [size=256]
Comment 3 Arjan van de Ven 2002-06-04 10:00:30 EDT
The current rawhide kernel ought to have this fixed
Comment 4 Daniel Powell 2002-06-08 12:34:11 EDT
Using kernel from RAWHIDE. 2.4.18-5.44smp i686
Looks like it is fixed.... Maybe this will stop all the crashing Ive had. Any 
heavy disk activity kills the kernel under the one shipped with 7.3 2.4.18-3. 
Will test some more.

[root@absolut log]# cat /proc/ide/hpt366 

                             HighPoint HPT366/368/370/372/374

Controller: 0
Chipset: HPT366
--------------- Primary Channel --------------- Secondary Channel --------------
Enabled:        yes                             yes
--------------- drive0 --------- drive1 ------- drive0 ---------- drive1 -------
DMA capable:    yes              yes            no                no 
Mode:           UDMA             UDMA           off               off 

Controller: 1
Chipset: HPT366
--------------- Primary Channel --------------- Secondary Channel --------------
Enabled:        yes                             yes
--------------- drive0 --------- drive1 ------- drive0 ---------- drive1 -------
DMA capable:    yes              yes            no                no 
Mode:           UDMA             UDMA           off               off
Comment 5 Arjan van de Ven 2002-06-20 09:42:49 EDT
fixed in the 2.4.18-5 kernel
Comment 6 Need Real Name 2002-08-23 04:58:20 EDT
Still segfaults for me with RH7.3's errata kernels kernel-2.4.18-5.i686.rpm and
kernel-2.4.18-10.i686.rpm. 


Note You need to log in before you can comment on or make changes to this bug.