This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 651723 - virt-install is unable to install on lvm disk
virt-install is unable to install on lvm disk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-10 02:46 EST by Mohammad Mateen
Modified: 2013-01-09 06:42 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-14 10:14:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mohammad Mateen 2010-11-10 02:46:51 EST
Description of problem: virt-install is unable to install on lvm disk


Version-Release number of selected component (if applicable):
python-virtinst-0.500.4-1.fc14.noarch
qemu-0.13.0-1.fc14.i686


How reproducible:
# virt-install -n vm1 -r 1024  -l /tmp/CentOS-5.5-i386-bin-DVD.iso --accelerate --os-type=linux -f /dev/VGDATA/vm1.root -f /dev/VGDATA/vm1.swap --vnc --hvm

Steps to Reproduce:
1.
2.
3.
  
Actual results:
# virt-install -n vm1 -r 1024  -l /tmp/CentOS-5.5-i386-bin-DVD.iso --accelerate --os-type=linux -f /dev/VGDATA/vm1.root -f /dev/VGDATA/vm1.swap --vnc --hvm

Starting install...
Retrieving file .treeinfo...                                                                                                          |  826 B     00:00 ... 
Retrieving file vmlinuz...                                                                                                            | 3.6 MB     00:00 ... 
Retrieving file initrd.img...                                                                                                         |  14 MB     00:00 ... 
ERROR    internal error Process exited while reading console log output: char device redirected to /dev/pts/1
qemu-kvm: -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-1,id=ide0-1-1: Can't use a read-only drive
qemu-kvm: -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-1,id=ide0-1-1: Device 'ide-drive' could not be initialized



Expected results:


Additional info: I think virt-install is unable to detect correct drivers for lvm and treating lvm as ide

I am getting following in logs:-

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-kvm -S -M pc-0.13 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name vm1 -uuid a6c42936-48e4-4bbb-0cb5-dac7508cc5a5 -nodefconfig -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/vm1.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=utc -no-reboot -boot c -kernel /var/lib/libvirt/boot/virtinst-vmlinuz.t4PmUk -initrd /var/lib/libvirt/boot/virtinst-initrd.img.u1iZpj -drive file=/dev/VGDATA/vm1.root,if=none,id=drive-ide0-0-0,boot=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/dev/VGDATA/vm1.swap,if=none,id=drive-ide0-0-1,format=raw -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -drive file=/tmp/CentOS-5.5-i386-bin-DVD.iso,if=none,id=drive-ide0-1-1,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-1,id=ide0-1-1 -device rtl8139,vlan=0,id=net0,mac=52:54:00:01:d2:d7,bus=pci.0,addr=0x3 -net tap,fd=44,vlan=0,name=hostnet0 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -vnc 127.0.0.1:0 -k en-us -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x4 
char device redirected to /dev/pts/1
qemu-kvm: -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-1,id=ide0-1-1: Can't use a read-only drive
qemu-kvm: -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-1,id=ide0-1-1: Device 'ide-drive' could not be initialized
Comment 1 Justin M. Forbes 2010-11-29 13:58:34 EST
I notice you are using i686 qemu.  Does this work with the most recent kernel from testing/koji?  I am not able to reproduce the lvm issues, but there is an issue with i686 kvm which is resolved with the latest koji kernels for F14.
Comment 2 Justin M. Forbes 2010-12-14 10:14:56 EST
Closing this one.  The i686 fix has been pushed to live, and I cannot reproduce.  Please feel free to reopen if the i686 updated kernel does not fix the issue for you.

Note You need to log in before you can comment on or make changes to this bug.