Bug 65183 - tamago causes extraneous emacs -q -batch output
tamago causes extraneous emacs -q -batch output
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tamago (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nakai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-19 13:35 EDT by Jay Berkenbilt
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-19 13:35:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2002-05-19 13:35:18 EDT
Description of Problem:

emacs -q batch --no-site-file generates extraneous output because of (message)
statements in /usr/share/emacs/site-lisp/egg/leim-list.el

Version-Release number of selected component (if applicable):

tamago-4.0.6-5

How Reproducible:

always

Steps to Reproduce:
1. run emacs -q -batch --no-site-file

Actual Results:

You see the following:

Finished loading /usr/share/emacs/site-lisp/egg/leim-list.el 
   and load others...
Loading /usr/share/emacs/21.2/leim/leim-list.el (source)...


Expected Results:

You should not get any output.

Additional Information:
	
This is the result of poor style in leim-list.el.  Some people may not consider
this a bug, but being able to use emacs -q -batch --no-site-file and have
predictable output is very useful for automated testing.

I'm surprised to see tamago installed with emacs 21.2.  I thought emacs 21
subsumed its functionality.  Prehaps I'm just confused.
Comment 1 Nakai 2002-05-24 05:34:19 EDT
Fix in tamago-4.0.6-8.src.rpm.
Comment 2 Nakai 2002-05-24 05:39:58 EDT
Additinally, it's decided tamago will not be in emacs 21 so
we need tamago for Japanese input on our future versions of
Red Hat Linux with emacs 21...

Note You need to log in before you can comment on or make changes to this bug.