Bug 65184 - Traceback (invalid certificate)
Traceback (invalid certificate)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-19 13:50 EDT by Milan Kerslager
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:46:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2002-05-19 13:50:25 EDT
I had an invalid certificate and up2date bomb out.

Here is a traceback:

Traceback (innermost last):
  File "/usr/sbin/up2date", line 1169, in ?
    main()
  File "/usr/sbin/up2date", line 254, in main
    up2date.updateLoginInfo()
  File "/usr/share/rhn/up2date_client/up2date.py", line 556, in updateLoginInfo
    loginInfo = login()
  File "/usr/share/rhn/up2date_client/up2date.py", line 487, in login
    loginInfo = doCall(server.up2date.login, systemId)
  File "/usr/share/rhn/up2date_client/up2date.py", line 426, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 689, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 746, in __request
    self.__protocol
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 652, in request
    return self.parse_response(fd)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 667, in 
parse_response
    return u.close()
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 366, in close
    raise apply(Fault, (), self._stack[0])
xmlrpclib.Fault: <Fault -9 """
Error Message:
    Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid Server Certificate.
Comment 1 Jay Turner 2002-05-20 08:58:03 EDT
Sounds as if you don't have a certificate at all on that machine.  The message
which is getting returned is to run 'rhn_register' on the machine to register it
with RHN.  Have you done that?
Comment 2 Milan Kerslager 2002-05-20 10:01:08 EDT
After I run rhn_register everything was ok. I saved traceback because up2date
should write error message more cleanly than bomb out.
Comment 3 Adrian Likins 2004-04-05 16:46:45 EDT
current releases should be better behaved.

Note You need to log in before you can comment on or make changes to this bug.