Bug 65216 - Kppp hangs in conjunction with kdesu
Kppp hangs in conjunction with kdesu
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-20 09:43 EDT by Remko Scharroo
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 15:46:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remko Scharroo 2002-05-20 09:43:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
I want to run kppp from the menu using "kdesu /usr/sbin/kppp" instead of needing all the gnome crap just to run consolehelper.
For all root-requiring packages (like kpackage and kuser) this works fine, but not for kppp.
What happens is this:
- Kppp starts up
- I select my connection
- It connects and starts ppp
- The two-eyed monitor does not start up and desktop switching is impossible.
- Only solution: kill kdesu. Then the two-eyed monitor pops up and everything keeps working even when I disconnect and reconnect again (without closing kppp).

This bug is fully reproducable, also when starting from the command line: "kdesu /usr/sbin/kppp"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in as non-root user
2. Type "kdesu /usr/sbin/kppp" in terminal
3. Type in root password
4. Make connection
 

Actual Results:  5. Connection is being made, as soon as ppp starts up: desktop swithching freezes and 2-eyed monitor does not pop up.
6. Kill kdesu in (other) terminal.
7. 2-eyed monitor pops up. Desktops are unfrozen.


Additional info:

This occurs, as far as I can tell since the introduction of KDE 3.0.0 in RedHat 7.2. It is still the case in RedHat 7.3.
Comment 1 Remko Scharroo 2002-05-20 22:11:29 EDT
Actually, the behaviour is slightly different. This might have changed since 
RedHat 7.2, I just got aware of it. 
1) kdesu /usr/sbin/kppp gives no problems when started from the command line 
in a terminal. 
2) When you make a .desktop file with the command "kdesu /usr/sbin/kppp" and 
put in on the desktop and click the icon on the desktop, everything works, 
accept that the desktop icons disappear when switching the desktop and remain 
gone until you quit kppp. 
3) When you put the .desktop file in your menu in ~/.kde/share/applnk or 
/usr/share/applnk, and start it from there, things work fine. 
4) When you put it as a button in the panel, and start it from there, all 
panel controls, such as changing the desktop freezes, until quitting kppp. 
The same happens, as it seems with other applications requiring kdesu.
Comment 2 Ngo Than 2003-09-03 15:46:20 EDT
It should fix this problem if you remove the line X-DCOP-ServiceType=Multi in
/usr/share/applnk/Internet/Kppp.desktop.

It's fixed in 3.1.3-4 or newer.

Note You need to log in before you can comment on or make changes to this bug.