Bug 652426 - [abrt] blogtk-1.1-14.fc14: ConfigParser.py:556:get:NoSectionError: No section: 'DefaultBlog'
Summary: [abrt] blogtk-1.1-14.fc14: ConfigParser.py:556:get:NoSectionError: No section...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blogtk
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Paul W. Frields
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:18a02c46
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-11 20:28 UTC by marian.trizuliak
Modified: 2012-03-10 14:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-10 14:05:23 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (762 bytes, text/plain)
2010-11-11 20:28 UTC, marian.trizuliak
no flags Details

Description marian.trizuliak 2010-11-11 20:28:24 UTC
abrt version: 1.1.13
architecture: i686
cmdline: python /usr/lib/python2.7/site-packages/blogtk/BloGTK.py
component: blogtk
executable: /usr/lib/python2.7/site-packages/blogtk/BloGTK.py
kernel: 2.6.35.6-48.fc14.i686.PAE
package: blogtk-1.1-14.fc14
reason: ConfigParser.py:556:get:NoSectionError: No section: 'DefaultBlog'
release: Fedora release 14 (Laughlin)
time: 1289507257
uid: 500

backtrace
-----
ConfigParser.py:556:get:NoSectionError: No section: 'DefaultBlog'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/blogtk/BloGTK.py", line 1245, in <module>
    blogtk = BloGTK()
  File "/usr/lib/python2.7/site-packages/blogtk/BloGTK.py", line 138, in __init__
    self.grabConfig()
  File "/usr/lib/python2.7/site-packages/blogtk/BloGTK.py", line 373, in grabConfig
    self.url = self.conf.get(self.sectionName, 'server')
  File "/usr/lib/python2.7/ConfigParser.py", line 556, in get
    raise NoSectionError(section)
NoSectionError: No section: 'DefaultBlog'

Local variables in innermost frame:
d: OrderedDict()
vars: None
self: <ConfigParser.ConfigParser instance at 0x99a9dac>
raw: False
section: 'DefaultBlog'
option: 'server'

How to reproduce
-----
1. Install Blogtk from repository
2. Run after install
3. Crash.

Comment 1 marian.trizuliak 2010-11-11 20:28:26 UTC
Created attachment 459839 [details]
File: backtrace

Comment 2 Paul W. Frields 2010-12-18 20:16:38 UTC
The 1.1 branch of BloGTK has basically been halted by its maintainer for
sometime. I can provide a 2.0 build of BloGTK for testing, but I won't push it
into Fedora 14 without positive reports from people on this bug.

The 2.0 build will be available in Rawhide (pre-Fedora 15) shortly.

Comment 3 Fedora Update System 2010-12-21 13:15:36 UTC
blogtk-2.0-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/blogtk-2.0-3.fc14

Comment 4 Fedora Update System 2010-12-22 00:02:57 UTC
blogtk-2.0-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blogtk'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/blogtk-2.0-3.fc14

Comment 5 Paul W. Frields 2010-12-31 13:11:36 UTC
Reminder: The update that fixes this bug will not be pushed to Fedora 14 unless test reports are filed in the Fedora update system here: https://admin.fedoraproject.org/updates/blogtk-2.0-3.fc14

This bug will remain open for five more days, and if there's no feedback by then it will be closed as NEXTRELEASE, since the problem is fixed in Fedora 15.

Comment 6 Vinzenz Vietzke 2011-01-22 09:51:56 UTC
Package: blogtk-1.1-14.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Set up new Blog
2. Closed BloGTK
3. Started BloGTK via command line

Comment 7 meine 2011-02-16 17:23:20 UTC
Package: blogtk-1.1-14.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. installed BloGTK via the Fedora 14 LXDE repo
2. chose application in application menu --> internet
3. got crash popup warning even before BloGTK showed up


Comment
-----
earlier installation prevented me from maging adjustments to the settings dialog, changes couldn't be saved. removed BloGTK via add/remove software. tried some other blogsloftware from the repo but decided to give BloGTK a 2nd chance...

Comment 8 Paul W. Frields 2011-02-16 21:41:07 UTC
Please refer to comment #5 above.  I've left the bug open in the hopes that people who were kind enough to take the time to report a problem would also be kind enough to (1) test the package update via the URL shown, and (2) report their feedback via that URL.  I realize the upstream's 1.1 branch is not usable, and would be happy to move Fedora 14 to the 2.0 branch once a sufficient number of people tell me the new app works better.

Comment 9 Vinzenz Vietzke 2011-02-16 22:39:22 UTC
(In reply to comment #8)
> Please refer to comment #5 above.  I've left the bug open in the hopes that
> people who were kind enough to take the time to report a problem would also be
> kind enough to (1) test the package update via the URL shown, and (2) report
> their feedback via that URL.  I realize the upstream's 1.1 branch is not
> usable, and would be happy to move Fedora 14 to the 2.0 branch once a
> sufficient number of people tell me the new app works better.

Hi,

sorry, I didn't see your posting as I reported the bug. Now I did some testing and reported on https://admin.fedoraproject.org/updates/blogtk-2.0-3.fc14.

Regards, vinz.

Comment 10 Fedora Update System 2011-08-01 15:41:58 UTC
blogtk-2.0-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/blogtk-2.0-4.fc14

Comment 11 Fedora Update System 2011-10-30 00:32:44 UTC
blogtk-2.0-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.