Bug 65249 - mkinird doesn't work with /etc/fstab.
mkinird doesn't work with /etc/fstab.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
: 66895 97084 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-20 18:04 EDT by hjl
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-20 18:05:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to support comments in /etc/fstab (535 bytes, patch)
2002-05-20 18:05 EDT, hjl
no flags Details | Diff
fix for comment intolerance: also kill two vars with one awk (701 bytes, patch)
2002-06-20 23:25 EDT, Curtis Doty
no flags Details | Diff

  None (edit)
Description hjl 2002-05-20 18:04:18 EDT
My fstab has

#LABEL=/                 /                       ext3    defaults        1 1
/dev/sda1               /                       ext3    defaults        1 1
#LABEL=/export           /export                 ext3    defaults        1 2
/dev/sdc1               /export                 ext3    defaults        1 2
/dev/sda6               /export/redhat          ext3    defaults        1 2
/dev/sdb1               /export/redhat/mirror   ext3    defaults        1 2
/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0
#LABEL=/usr              /usr                    ext3    defaults        1 2
/dev/sda2                /usr                    ext3    defaults        1 2
#LABEL=/var              /var                    ext3    defaults        1 2
/dev/sda5                /var                    ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/sda3               swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0 
0
/dev/cdrom1             /mnt/cdrom1             iso9660 noauto,owner,kudzu,ro 0 
0

Upgrade to 7.3 made my machine panic during boot.
Comment 1 hjl 2002-05-20 18:05:09 EDT
Created attachment 58045 [details]
A patch to support comments in /etc/fstab
Comment 2 Erik Troan 2002-05-20 21:18:11 EDT
Yikes! Hard to believe this has been in there so long. Almost the same fix applied:

  rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' $fstab)

Let me (ewt@redhat.com -- mail me directly) know if you see any problems with
this alternate fix.
Comment 3 Pete Zaitcev 2002-06-19 15:09:12 EDT
*** Bug 66895 has been marked as a duplicate of this bug. ***
Comment 4 Curtis Doty 2002-06-20 23:23:50 EDT
I got so excited with this bugly I fixed it before checking bugzilla. Zoinks. 
Follows is alternate patch with less cruft.
Comment 5 Curtis Doty 2002-06-20 23:25:28 EDT
Created attachment 61987 [details]
fix for comment intolerance: also kill two vars with one awk
Comment 6 Pete Zaitcev 2002-08-06 19:24:03 EDT
mkinitrd-3.4.20-1 seems to work fine, installs on 7.3 fine
(I did rpm -U).
Comment 7 Jeremy Katz 2003-06-10 23:33:08 EDT
*** Bug 97084 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.