Bug 652490 - mbp_nvidia_bl do not change the brightness
mbp_nvidia_bl do not change the brightness
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-11 21:05 EST by Michael Scherer
Modified: 2013-01-10 03:14 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-03 07:37:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2010-11-11 21:05:54 EST
Description of problem:
Since the upgrade to Fedora 14 ( but maybe before, on F13 too ), the brigthness cannot be changed, either using xrandr, xbacklight or gnome tools. After searching, I have seen that it doesn't work even when I use echo > /sys/class/backlight/mbp_backlight/brightness . No matter what I do, nothing change.

It used to work fine before.

I have a macbook 2.1, from 2008, with a intel graphic adapter :
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Version-Release number of selected component (if applicable):

 $ uname -a
Linux akroma.ephaone.org 2.6.35.6-48.fc14.i686.PAE #1 SMP Fri Oct 22 15:27:53 UTC 2010 i686 i686 i386 GNU/Linux

$ rpm -qa | grep intel
xorg-x11-drv-intel-2.12.0-6.fc14.1.i686
intel-gpu-tools-2.12.0-6.fc14.1.i686

How reproducible:
Each time

Steps to Reproduce:
1.try to reduce the brightness using the keyboard

  
Actual results:
Nothing change.

Expected results:
Brightness is adjusted.

Additional info:
When I load the module with debug=1, here is what I have in the log :

[  846.519268] mbp_nvidia_bl: MacBook 2,1 detected
[  846.520881] mbp_nvidia_bl: read brightness of 0
[  846.520886] mbp_nvidia_bl: setting brightness to 0

Here, I have used "F2" ( more brightness ) twice :

[  854.749186] mbp_nvidia_bl: read brightness of 0
[  854.749378] mbp_nvidia_bl: setting brightness to 0
[  854.755179] mbp_nvidia_bl: setting brightness to 1
[  854.759274] mbp_nvidia_bl: read brightness of 0
[  854.759301] mbp_nvidia_bl: setting brightness to 0
[  855.292297] mbp_nvidia_bl: read brightness of 0
[  855.292332] mbp_nvidia_bl: setting brightness to 0
[  855.293156] mbp_nvidia_bl: setting brightness to 1
[  855.298725] mbp_nvidia_bl: read brightness of 0
[  855.298754] mbp_nvidia_bl: setting brightness to 0
[  855.741095] mbp_nvidia_bl: read brightness of 0
[  855.741128] mbp_nvidia_bl: setting brightness to 0
[  855.742047] mbp_nvidia_bl: setting brightness to 1
[  855.747755] mbp_nvidia_bl: read brightness of 0
[  855.747784] mbp_nvidia_bl: setting brightness to 0


Here, I have used "F1" ( less brightness ) twice :

[  866.501147] mbp_nvidia_bl: read brightness of 0
[  866.501208] mbp_nvidia_bl: setting brightness to 0
[  866.504189] mbp_nvidia_bl: read brightness of 0
[  866.504242] mbp_nvidia_bl: setting brightness to 0
[  867.044939] mbp_nvidia_bl: read brightness of 0
[  867.045024] mbp_nvidia_bl: setting brightness to 0
[  867.047996] mbp_nvidia_bl: read brightness of 0
[  867.048074] mbp_nvidia_bl: setting brightness to 0

I run the fedora system directly with the EFI ( ie, without bootcamp, with grub 2 ). The brightness adjustement still work on os x, but I am unable to see what ports are used by darwin to communicate with the graphic adapter.
I do not know if it matter, but plymouth too is not working, but I suspect it may be a different problem.
Comment 1 Marius Andreiana 2010-11-12 14:50:22 EST
dupe of #539961 ?
Comment 2 Michael Scherer 2010-11-14 18:58:39 EST
The symptom look the same indeed, but I would not have filled it against hal, as it seems to be lower in the stack. Now, maybe there was a change in hal that exposed the issue in the module, or maybe that the module is not meant to be used on this precise hardware, or maybe there was a change in the firmware done by apple leading to the breakage on linux, I do not know.
The module look like simple enough to not have a bug, so I suspect a change on Apple side.
Comment 3 Josh Boyer 2011-09-21 13:11:08 EDT
Is this still happening on the latest F14/F15 kernel?
Comment 4 Michael Scherer 2011-09-21 15:51:39 EDT
Yes, I see it on  2.6.40.4-5.fc15.i686.PAE
Comment 5 Josh Boyer 2011-09-21 15:57:48 EDT
OK, I'm going to move this to F15 then.
Comment 6 Michael Scherer 2011-10-03 07:04:32 EDT
I upgraded on f16, and the issue is fixed there ( which also mean that i can hardly test any fix proposed for f15 :/ )
Comment 7 Josh Boyer 2011-10-03 07:37:05 EDT
(In reply to comment #6)
> I upgraded on f16, and the issue is fixed there ( which also mean that i can
> hardly test any fix proposed for f15 :/ )

Thank you for letting us know.  I'll close this as NEXTRELEASE.  Enjoy F16!

Note You need to log in before you can comment on or make changes to this bug.