Bug 652521 - Remember alarm's last notified per calendar
Remember alarm's last notified per calendar
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.6
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
: Patch
Depends On:
Blocks: 743405 1002709 569781
  Show dependency treegraph
 
Reported: 2010-11-12 00:56 EST by ritz
Modified: 2013-10-06 21:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:49:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch based on upstream code (5.72 KB, patch)
2010-11-12 00:56 EST, ritz
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 579646 None None None Never

  None (edit)
Description ritz 2010-11-12 00:56:48 EST
Created attachment 459920 [details]
patch based on upstream code

Description of problem:
Most visible with calendars requiring passwords, but users don't want to store
calendar password within evolution, they rather enter it each start.

For such calendars the alarm notification is not run on start, but rather
later, when the password is known, which means all the alarms in time of
not-active can be lost.

Thus I would suggest to store last-notification time per calendar, say as a
property in an ESource, and when not known, then choose date say a week back,
to rather re-notify for older events than lost them at all.


Version-Release number of selected component (if applicable):
evolution-2.12.3-19

How reproducible:
always

Steps to Reproduce:
1. Create an appointment which pops up in 20mins, with alarm 15mins ahead

  
Actual results:
No notification

Expected results:
Notification


Additional info:
Comment 1 RHEL Product and Program Management 2011-05-31 11:06:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-06-11 21:26:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 Andrius Benokraitis 2013-10-06 21:49:21 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.