This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 652587 - perl-libguestfs is incorrect sub-package
perl-libguestfs is incorrect sub-package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
rawhide
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-12 04:36 EST by Marcela Mašláňová
Modified: 2010-11-16 04:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 17:38:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2010-11-12 04:36:00 EST
Usually sub-packages for languages are created as %{nameofyourpackage}-perl. If you named it perl-libguestfs, then it sounds like main perl package. I can't find any rule in packaging guidelines, but you can check with
'yum search -- -perl'
that most of packages have it opposite way than you have.

I suppose it's not easy to change it, but it could be possible.
Comment 1 Richard W.M. Jones 2010-11-12 08:31:28 EST
I think it really should be perl-Sys-Guestfs.  I guess we should
change this.
Comment 2 Richard W.M. Jones 2010-11-13 04:48:51 EST
Marcela we're ready to change this to 'perl-Sys-Guestfs' which
appears to be the logical name for this (cf perl-Sys-Virt
for example).

Is this good?
Comment 3 Marcela Mašláňová 2010-11-15 01:37:22 EST
Yes, it looks correct.
Comment 4 Richard W.M. Jones 2010-11-15 05:22:08 EST
Rawhide build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2601522
Comment 5 Richard W.M. Jones 2010-11-15 12:09:38 EST
Try this one instead:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2602282
Comment 6 Richard W.M. Jones 2010-11-15 17:38:36 EST
This is what the package looks like now:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=2258875

I should have added an Obsoletes line in there too.  I'll
put that in at the next release.
Comment 7 Richard W.M. Jones 2010-11-16 03:38:44 EST
I did an upgrade from 1.7.6 -> 1.7.8 and the perl-libguestfs
package was correctly obsoleted and replaced by the new package.

Dependencies Resolved

================================================================================
 Package                     Arch        Version                Repository
                                                                           Size
================================================================================
Installing:
 perl-Sys-Guestfs            x86_64      1:1.7.8-1.fc15         koji      230 k
     replacing  perl-libguestfs.x86_64 1:1.7.6-1.fc15
Updating:
 libguestfs                  x86_64      1:1.7.8-1.fc15         koji      1.2 M
Updating for dependencies:
 guestfish                   x86_64      1:1.7.8-1.fc15         koji      224 k
 libguestfs-devel            x86_64      1:1.7.8-1.fc15         koji      331 k
 libguestfs-java             x86_64      1:1.7.8-1.fc15         koji       88 k
 libguestfs-java-devel       x86_64      1:1.7.8-1.fc15         koji       35 k
 libguestfs-javadoc          x86_64      1:1.7.8-1.fc15         koji       90 k
 libguestfs-mount            x86_64      1:1.7.8-1.fc15         koji       58 k
 libguestfs-tools            x86_64      1:1.7.8-1.fc15         koji      130 k
 ocaml-libguestfs            x86_64      1:1.7.8-1.fc15         koji      111 k
 ocaml-libguestfs-devel      x86_64      1:1.7.8-1.fc15         koji      108 k
 php-libguestfs              x86_64      1:1.7.8-1.fc15         koji       70 k
 python-libguestfs           x86_64      1:1.7.8-1.fc15         koji      108 k
 ruby-libguestfs             x86_64      1:1.7.8-1.fc15         koji       74 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade      13 Package(s)

Total download size: 2.9 M
Is this ok [y/N]: y
Comment 8 Marcela Mašláňová 2010-11-16 04:15:11 EST
Great. perl-Sys-Guestfs should also provides itself, but that might be already done automatically by rpm magic.

Note You need to log in before you can comment on or make changes to this bug.