Bug 65290 - remote authentication of root account that uses bash-2.05a prints $TERM error
remote authentication of root account that uses bash-2.05a prints $TERM error
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 11:42 EDT by Mike Snitzer
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 11:55:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Snitzer 2002-05-21 11:42:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
When using rsh, ssh, rcp, rexec, etc. as the root user (uid=0) the following
$TERM error will occur if the serverside host has a root account that uses
bash-2.05a (in this example client and server are the same):

[root@xeon1 ~]# rsh -d xeon3 uname -r
No value for $TERM and no -T specified
No value for $TERM and no -T specified
2.4.17-plogic-10smp
[root@xeon1 ~]# ssh localhost uname -r
root@localhost's password: 
No value for $TERM and no -T specified
No value for $TERM and no -T specified
2.4.17-plogic-10smp

This $TERM error results from the server side root account using RH7.3's
bash-2.05a.  If I downgrade to RH7.2's bash (2.05-8) all works perfectly fine.

Also, if I switch to a user account and rsh, ssh, or whatever all appears to be
fine with bash-2.05a:

[root@xeon1 ~]# rpm -q bash
bash-2.05a-13
[root@xeon1 ~]# su - paralogic
[paralogic@xeon1 paralogic]$ rsh xeon1 uname -r
2.4.17-plogic-10smp 

Version-Release number of selected component (if applicable):
2.05a-13

How reproducible:
Always

Steps to Reproduce:
1.(as root using bash-2.05a) rsh localhost uname -r
2.or rsh/ssh a command to a remote system where root's shell is bash-2.05a
3.the command will execute fine; but the following errors will spew prior to the
command's output:
No value for $TERM and no -T specified
No value for $TERM and no -T specified


Actual Results:  the rsh/rcp/rexec/ssh/scp command will execute fine; but the
following errors will spew prior to the command's output:
No value for $TERM and no -T specified
No value for $TERM and no -T specified

Expected Results:  the command should return without error messages, i.e.
without: "No value for $TERM and no -T specified"

Additional info:

I haven't tried to completely track down why the environment isn't getting setup
through rsh or ssh command execution.  On the client side the $TERM variable is
set to xterm.  And rsh/ssh localhost echo $TERM prints xterm; so I'm not sure
what the story is.

For now I've just downgraded to rh7.2's bash-2.05-8
Comment 1 Bernhard Rosenkraenzer 2002-05-22 05:48:41 EDT
This is almost certainly related to your bash startup scripts, since it's not 
reproducable here. 
 
What are you doing in root's .bashrc, .bash_profile, ...? 
Probably some setterms?
Comment 2 Tim Waugh 2002-10-11 07:17:18 EDT
*ping*

Note You need to log in before you can comment on or make changes to this bug.