Bug 65291 - chinput does not start because of missing font
Summary: chinput does not start because of missing font
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: miniChinput   
(Show other bugs)
Version: 7.3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-21 15:52 UTC by Need Real Name
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-24 19:55:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-05-21 15:52:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020405

Description of problem:
When login in with Chinese simplified (gb2312.1980) chinput is not working.
Starting it by hand shows that it exits because it can't get the proper fonts
from the font server:
$ chinput 
Chinput Version 3.0.2 -- XIM Server
Distributed under the terms of the GNU General Public License (GPL)
Basic: Cannot open font -misc-zysong18030-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0

$ fslsfonts -server unix/:7100 | grep zysong  
-misc-zysong18030-medium-r-normal--0-0-0-0-c-0-ascii-0
-misc-zysong18030-medium-r-normal--0-0-0-0-c-0-iso10646-1

[bobo@fpn usr]$ ttfinfo /usr/share/fonts/zh_CN/TrueType/zysong.ttf
TTFINFO_FONT_FILE="/usr/share/fonts/zh_CN/TrueType/zysong.ttf"
TTFINFO_FONT_NAME="ZYSong18030"
TTFINFO_FOUNDRY_NAME="misc"
TTFINFO_WEIGHT_NAME="medium"
TTFINFO_WIDTH="normal"
TTFINFO_NUMCMAP="1"
TTFINFO_CMAP0="3,1"
TTFINFO_CMAPNAME0="Windows,Unicode"
TTFINFO_MAPNUM="1"
TTFINFO_FONTMAP1="-misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0"

versions:
XFree86-xfs-4.2.0-8
ttfonts-zh_CN-2.11-21
miniChinput-0.0.3-18
XFree86-4.2.0-8


The system was upgraded from Redhat 7.2 - it used to work under 7.2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.login with Chinese simplified
2.press <ctrl><space>

	

Actual Results:  nothing

ps auxww | grep chinput should show chinput running.

Expected Results:  the input window should have come up

Additional info:

Comment 1 Yu Shao 2002-05-22 00:14:32 UTC
The problem is /usr/share/fonts/zh_CN/Truetype/fonts/fonts.dir hasn't been
updated, you can use the following steps to update it manually.

# cd /usr/share/fonts/zh_CN/TrueType
# ttmkfdir -e /usr/X11R6/lib/X11/fonts/encodings/encodings.dir -x 2 > fonts.scale
# mkfontdir

It should solve your problem.


Comment 2 Need Real Name 2002-05-24 19:55:24 UTC
Ok, that helped, but shouldn't fonts.dir have been updated during the upgrade,
when the ttfonts-zh_CN-2.11-21 rpm got installed?

Thanks,
 anyway Florian



Note You need to log in before you can comment on or make changes to this bug.