Bug 652928 - [abrt] MyPasswordSafe-0.6.7-9.20061216.fc12: Process /usr/bin/MyPasswordSafe was killed by signal 6 (SIGABRT)
Summary: [abrt] MyPasswordSafe-0.6.7-9.20061216.fc12: Process /usr/bin/MyPasswordSafe ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: MyPasswordSafe
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Ralf Ertzinger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f8f4444ac3aee3022f4f536c365...
: 590267 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-13 15:22 UTC by Daniel Scott
Modified: 2010-11-22 22:17 UTC (History)
2 users (show)

Fixed In Version: MyPasswordSafe-0.6.7-11.20061216.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 22:17:53 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (48.66 KB, text/plain)
2010-11-13 15:22 UTC, Daniel Scott
no flags Details

Description Daniel Scott 2010-11-13 15:22:54 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: MyPasswordSafe
component: MyPasswordSafe
executable: /usr/bin/MyPasswordSafe
kernel: 2.6.35.6-48.fc14.x86_64
package: MyPasswordSafe-0.6.7-9.20061216.fc12
reason: Process /usr/bin/MyPasswordSafe was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1289616216
uid: 500

How to reproduce
-----
1. Attempt to export as xml
2.
3.

Comment 1 Daniel Scott 2010-11-13 15:22:56 UTC
Created attachment 460245 [details]
File: backtrace

Comment 2 Ralf Ertzinger 2010-11-13 17:02:26 UTC
is this reproducable on your side? I suspect it depends on the content of the safe you're trying to export, and I cannot make it crash here so far.

Comment 3 Ralf Ertzinger 2010-11-13 17:10:32 UTC
*** Bug 590267 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Scott 2010-11-13 17:37:18 UTC
Yes, it's reproducible here - it appears to have corrupted/altered the .dat file because I can't even open the safe any more.

I can still access all of the data through the command line 'pwsafe' though. :)

Comment 5 Ralf Ertzinger 2010-11-13 19:05:26 UTC
MyPasswordSafe usually creates a backup file with the same name as the original but ending in .dat~. You could try to restore that.

Can you try this package:
http://koji.fedoraproject.org/koji/getfile?taskID=2599224&name=MyPasswordSafe-0.6.7-10.1.20061216.fc14.x86_64.rpm

and tell me whether it fixes the bug?

Comment 6 Daniel Scott 2010-11-13 19:40:19 UTC
Yep, that new package has fixed it. I can open the file and export as XML. Thanks.

Comment 7 Ralf Ertzinger 2010-11-13 20:18:29 UTC
Thanks. An update will be built and pushed out in due course. This will replace the package you downloaded manually, but the contents will be the same.

Comment 8 Fedora Update System 2010-11-13 22:32:00 UTC
MyPasswordSafe-0.6.7-11.20061216.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/MyPasswordSafe-0.6.7-11.20061216.fc14

Comment 9 Fedora Update System 2010-11-14 21:27:28 UTC
MyPasswordSafe-0.6.7-11.20061216.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update MyPasswordSafe'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/MyPasswordSafe-0.6.7-11.20061216.fc14

Comment 10 Fedora Update System 2010-11-22 22:17:49 UTC
MyPasswordSafe-0.6.7-11.20061216.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.