Bug 653006 - The dkms package fails to bring in a cc as a dependency
Summary: The dkms package fails to bring in a cc as a dependency
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dkms
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matt Domsch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 03:22 UTC by Christopher Swift
Modified: 2010-11-14 04:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-14 04:41:59 UTC
Type: ---


Attachments (Terms of Use)
The vbox-install log (3.71 KB, text/x-log)
2010-11-14 03:22 UTC, Christopher Swift
no flags Details

Description Christopher Swift 2010-11-14 03:22:54 UTC
Created attachment 460296 [details]
The vbox-install log

Description of problem: DKMS fails to bring in a cc (such as gcc) as a dependency or check if one exists therefore it fails to build modules when required.


Version-Release number of selected component (if applicable): 2.1.0.1


Steps to Reproduce:
1. su -c "yum install dkms"
2. Try to do something that depends on dkms such as VirtualBox "su -c '/etc/init.d/vboxdrv setup'"
3. It should install dkms and kernel-devel but not gcc
  
Actual results:
gcc isn't installed so the modules cannot be built.
"sudo /etc/init.d/vboxdrv setup" returns:
[chris@ianto-amd-fedora ~]$ sudo /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel modules                         [  OK  ]
Uninstalling old VirtualBox DKMS kernel modules            [  OK  ]
Trying to register the VirtualBox kernel modules using DKMS
Error! Bad return status for module build on kernel: 2.6.35.6-48.fc14.x86_64 (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/vboxhost/3.2.10/build/ for more information.

DO YOU HAVE gcc INSTALLED???
                                                           [FAILED]
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules                      [FAILED]
  (Look at /var/log/vbox-install.log to find out what went wrong)

I have attached /var/log/vbox-install.log

Expected results:
Install or check for a cc prior to installing dkms as it cannot compile modules without one.
"sudo /etc/init.d/vboxdrv setup'" returns:
[chris@ianto-amd-fedora ~]$ sudo /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel modules                         [  OK  ]
Uninstalling old VirtualBox DKMS kernel modules            [  OK  ]
Trying to register the VirtualBox kernel modules using DKMS[  OK  ]
Starting VirtualBox kernel modules                         [  OK  ]


Additional info:
On the dkms mailing list there is post explaining the removal of gcc as a dependency here: http://lists.us.dell.com/pipermail/dkms-devel/2004-May/000092.html
However Fedora should be able to check if there is a C compiler installed on the system so that it's possible that dkms can function as intended. Without a compiler dkms has no use.

Comment 1 Christopher Swift 2010-11-14 03:24:08 UTC
Attached is a copy of the /var/log/vbox-install.log log.

Comment 2 Matt Domsch 2010-11-14 04:41:59 UTC
Without a compiler, DKMS still has a very legitimate use as the runtime installer for pre-compiled modules, and as such is usable on systems where the system administror's policy is to not include compilers on the local system.

DKMS does emit the message noted above "DO YOU HAVE gcc INSTALLED?" to alert you to this fact.


Note You need to log in before you can comment on or make changes to this bug.