This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 65321 - ide-scsi does not work for either cd or tape device
ide-scsi does not work for either cd or tape device
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 19:21 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-22 18:02:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-21 19:21:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (WinNT; U)

Description of problem:
have added  append "hdc=ide-scsi" to my grub.conf and /sbin/insmod ide-scsi to my /etc/rc.d/rc.local (and similar for the tape device)
The ide-scsi emulator does not seem to be doing anything, though if I try to reload it, I do get a message saying
Using /lib/modules/2.4.18-4/kernel/drivers/scsi/ide-scsi.o 
The ide-scsi worked as expected in redhat 7.2
 insmod: a module named ide-scsi  already exists.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.modify grub.conf to include append="hdc=ide-scsi"
2.reboot
3.insmod ide-scsi
4.try to use the ide-scsi device
	

Actual Results:  cdrecord -scanbus results in cdrecord: No such file or directory. Cannot open scsi driver.
tar cfv /dev/st0 directoryname results in tar: /dev/st0: cannot open: No such device

Expected Results:  the cdrecord should list available scsi devices
the tar should write to the tape.

Additional info:

The ide-scsi tape device worked under redhat 7.2.  No ide-scsi has worked since upgrading my kernel.
Comment 1 Arjan van de Ven 2002-05-22 07:27:34 EDT
append "hdc=ide-scsi" to my grub.conf 

hmmm grub doesn't understand "append" lines, you need to add the thing
to append at the end of the line with "vmlinuz" in it!
Comment 2 Need Real Name 2002-05-22 18:02:18 EDT
Right you are.  
Getting rid of the append lines solved the problem.

Curious that the old grub.conf did work under redhat7.2

Note You need to log in before you can comment on or make changes to this bug.