Bug 65323 - ksconfig is willing to set partition size to 0.
Summary: ksconfig is willing to set partition size to 0.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ksconfig   
(Show other bugs)
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-21 23:56 UTC by Andrew Schultz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-22 19:50:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Schultz 2002-05-21 23:56:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux alpha; en-US; rv:1.0rc1) Gecko/20020424

Description of problem:
If the partition size is not set, ksconfig will not allow you to leave the
dialog.  However, if you click on the size textbox without entering a value and
then do something else (click enter or go on to other options), it will make
size 0.  This is an obvious nonsense setting with "fixed size", but with --grow,
it seems like it wouldn't be too bad.  The problem is that anaconda interprets
size 0 as "not size" and complains that you haven't set size.

Also, if you set size to a negative value, it will make it 0.

ksconfig should make the minimum 1 instead of 0.

Version-Release number of selected component (if applicable):
2.0-7 and also 1.9.8-4 (RH7.2)

How reproducible:
Always

Steps to Reproduce:
1. add a new partition
2. mount point='/'
3. [tab][tab][tab]
4. select "fill to maximum size"
5. click ok

Actual Results:
ks.cfg contains the following:
part / --fstype ext3 --size 0 --grow 

anaconda chokes

Expected Results:
part / --fstype ext3 --size 1 --grow

Comment 1 Brent Fox 2002-05-22 16:26:38 UTC
Thanks for your report.  I'll take a look at this today.

Comment 2 Brent Fox 2002-05-22 16:29:52 UTC
Hmmm, I agree that there's a ksconfig bug here, but it also seems like a GTK bug
as well.  When I <Tab> into the size SpinButton, the entry is blank.  But when I
<Tab> out of it, it sets the value to zero.  That doesn't seem right.  It should
just leave the value blank.

Comment 3 Brent Fox 2002-05-22 19:50:38 UTC
After playing around with GTK2, it appears that GTK2 behaves differently.  I
suspect that this entire problem is caused by the GTK 1.2 SpinButton problem (or
at least a problem with using Glade with GTK 1.2).  I plan on porting ksconfig
to GTK 2 for the next version, but I'll see if I can find a workaround for GTK 1.2.

Comment 4 Brent Fox 2002-05-22 20:09:18 UTC
Ok, I flipped some bits in the Glade file so it's now honoring the minimum value
of 1, because 0 MB makes no sense in any regard.  So it's now behaving the way
that you requested.  A new version will appear in Rawhide soon.
ksconfig-2.0-9.noarch.rpm

Thanks for your report and thanks for using Red Hat Linux.


Note You need to log in before you can comment on or make changes to this bug.