Bug 65332 - Error finding/loading font sets when starting up2date
Error finding/loading font sets when starting up2date
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 05:55 EDT by Anders Norrbring
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 23:00:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Norrbring 2002-05-22 05:55:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When I connect to the linux via F-Secure ssh2 and X-Win32 in combination and 
try to run up2date from the workstation I get lots of error messages about 
missing fonts.  The first screen in up2date is also completely blank, except 
for the buttons at the bottom.

The system is installed as a server, with both Gnome and KDE and all pre-
selected fonts.  2 languages are installed, default English and Swedish.

A short screen-shot from the ssh window is found pasted in here below. There 
are many more like these, I just thought it would be unnecessary to paste them 
here... They list just about every font imaginable.


[root@berit root]# up2date
The font "-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1,
                  -*-arial-medium-r-normal--12-*-*-*-*-*-iso8859-1,
                  -*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-15,
                  -*-arial-medium-r-normal--12-*-*-*-*-*-iso8859-15,*-r-*" 
does not support all the required character sets for the current 
locale "LC_CTYPE=en_US.iso885915;LC_NUMERIC=C;LC_TIME=en_US.iso885915;LC_COLLAT
E=en_US.iso885915;LC_MONETARY=en_US.iso885915;LC_MESSAGES=en_US.iso885915;LC_PA
PER=en_US.iso885915;LC_NAME=en_US.iso885915;LC_ADDRESS=en_US.iso885915;LC_TELEP
HONE=en_US.iso885915;LC_MEASUREMENT=en_US.iso885915;LC_IDENTIFICATION=en_US.iso
885915"
  (Missing character set "ISO8859-15")
  (Missing character set "ISO8859-15")
The font "-adobe-helvetica-bold-r-normal-*-*-180-*-*-p-*-iso8859-1,*-r-*" does 
not support all the required character sets for the current 
locale "LC_CTYPE=en_US.iso885915;LC_NUMERIC=C;LC_TIME=en_US.iso885915;LC_COLLAT
E=en_US.iso885915;LC_MONETARY=en_US.iso885915;LC_MESSAGES=en_US.iso885915;LC_PA
PER=en_US.iso885915;LC_NAME=en_US.iso885915;LC_ADDRESS=en_US.iso885915;LC_TELEP
HONE=en_US.iso885915;LC_MEASUREMENT=en_US.iso885915;LC_IDENTIFICATION=en_US.iso
885915"
  (Missing character set "ISO8859-15")
  (Missing character set "ISO8859-15")


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Exit the app and restart it
2. After reboot it comes up again.
3.
	

Actual Results:  Same as in the problem description above.

Expected Results:  I hoped it would be an absolutely clean startup, like in my 
previous v7.2 install, also I suspect there would be some kind of text 
information in the first, blank screen?

Additional info:
Comment 1 Adrian Likins 2002-08-08 23:00:48 EDT
Hmm, never seen this before. 

First impression is that this is probabaly more of
a Gtk+ issue than an up2date one (no where in the
up2date code does it print out errors like that...)

Do other pygtk apps work okay (say, printconf-gui?)

Up2date doesnt really expect much from it's fonts,
so I'm not sure what the root of this issue is.
Comment 2 Adrian Likins 2002-08-08 23:36:13 EDT
On investigation, it looks like the Xserver in question doesnt
have the approriate fonts to use the iso-8859-15 locale.

You can:
     - set LC_ALL=en_US  
     - install  iso-8859-15 on the Xserver
     - just ignore it


Note You need to log in before you can comment on or make changes to this bug.