Bug 65347 - adsl connection does not work
adsl connection does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
7.3
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 10:59 EDT by Need Real Name
Modified: 2007-03-26 23:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 09:51:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-22 10:59:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Windows NT 5.0; U)

Description of problem:
Configured my adsl the same as in 7.2 but cannot get ppp0 to talk to ethernet card (works fine in 7.2). Have tried both upgrading from 7.2 to 7.3 
and 
installing 7.3 from scratch.  Modem shows to connect but no traffic in tcpdump from ppp0.
nic - kne110tx
modem - speedstream

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.configure xdsl

2.activate ppp0, shows active, gets ip from isp

3. no traffic on ppp0
	

Additional info:
Comment 1 Ngo Than 2002-06-02 13:00:49 EDT
If you use monitor in redhat-config-network, it should work. It's a bug in 
tcpdump.
Comment 2 Need Real Name 2002-06-02 19:59:26 EDT
Does not work with monitor either.  I can get the connection to work by connecting to my ISP and setting the default route to my ISP and dev 
ppp0.  Used the ip route procedure in bug #64574.
Comment 3 Harald Hoyer 2002-06-24 09:56:44 EDT
is there any real traffic? can you browse the web? are you really connected?
Comment 4 Need Real Name 2002-06-24 14:27:05 EDT
Yes I am really connected.  After the adsl connection is made I run ifconfig to
get the default gateway for my ppp0 connection.  I then do the following:

/sbin/ip route delete default
/sbin/ip route add default via xxx.xxx.xxx.xxx dev ppp0

where xxx.xxx.xxx.xxx is the gateway address from ifconfig.
After this, I have access to the internet.
Comment 5 Harald Hoyer 2002-06-25 04:48:33 EDT
I have no problems doing:
# tcpdump -i ppp0

Hmm... strange..
Comment 6 Harald Hoyer 2002-06-25 04:50:28 EDT
"cannot get ppp0 to talk to ethernet card" - what do you mean by this? no ppp
over ethernet?

Note You need to log in before you can comment on or make changes to this bug.