Bug 653508 - cman_tool does not display node votes
Summary: cman_tool does not display node votes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman
Version: 5.6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 16:08 UTC by Christine Caulfield
Modified: 2018-11-14 20:12 UTC (History)
3 users (show)

Fixed In Version: cman-2.0.115-71.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-21 07:16:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch to add Votes display to cman_tool. (564 bytes, patch)
2010-11-15 16:08 UTC, Christine Caulfield
lhh: review+
Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1001 0 normal SHIPPED_LIVE cman bug-fix and enhancement update 2011-07-20 15:44:50 UTC

Description Christine Caulfield 2010-11-15 16:08:48 UTC
Created attachment 460565 [details]
Patch to add Votes display to cman_tool.

Description of problem:

The 'cman_tool status' command does not display the votes of the nodes in the cluster. RHEL4 did this.


Version-Release number of selected component (if applicable):
Version 5.0+

How reproducible:
every time

Steps to Reproduce:
1. cman_tool statu, case 00316347
  
Actual results:
Votes are not shown from the command, nor from cman_tool nodes

Expected results:
It's useful to know the current votes number for a node. 

Additional info:
RHEL4 showed votes for all the nodes in the cluster in the cman_tool nodes command. While this isn't possible in RHEL5 without messing up the cman/libcman interface, just showing the local votes value is useful.

This is a customer request, case 00316347

Comment 3 RHEL Program Management 2011-01-11 19:49:44 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Program Management 2011-01-11 22:21:01 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 6 Dean Jansa 2011-05-16 21:08:26 UTC
[root@marathon-03 ~]# cman_tool status | grep "Node votes:"
Node votes: 1


Verified in cman-2.0.115-82.el5

Comment 7 errata-xmlrpc 2011-07-21 07:16:20 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1001.html


Note You need to log in before you can comment on or make changes to this bug.