Bug 65353 - (NET EEPRO100) eepro100 driver shows initial packet loss
(NET EEPRO100) eepro100 driver shows initial packet loss
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 13:09 EDT by Raphael Clifford
Modified: 2013-07-02 22:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 03:01:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpdump capture of ping -s 8000 when first packet is lost (8.00 KB, text/plain)
2002-05-22 13:12 EDT, Raphael Clifford
no flags Details
tcpdump capture of ping -s 8000 when first packet is not lost (for comparison) (8.00 KB, text/plain)
2002-05-22 13:13 EDT, Raphael Clifford
no flags Details

  None (edit)
Description Raphael Clifford 2002-05-22 13:09:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.0+) Gecko/20020513

Description of problem:
Using redhat 7.3 and the 2.4.18-4 kernel and Cisco catalyst 6509 switch.    If I
ping -s 8000 from the node to one of the other non-redhat nodes (running linux
2.2.19) the first packet is lost.  If I then ping the *same* computer
immediately again then all packets get through.  If I then ping a different
computer the first packet is lost again.  If I wait for a bit and then go back
to the initial computer the cycle is restarted.

The card details on the redhat machine are:
00:10.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
        Subsystem: Intel Corp. EtherExpress PRO/100+ Management Adapter
        Flags: bus master, medium devsel, latency 64, IRQ 10
        Memory at febef000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at ef00 [size=64]
        Memory at fea00000 (32-bit, non-prefetchable) [size=1M]
        Expansion ROM at fe900000 [disabled] [size=1M]
        Capabilities: [dc] Power Management version 2

Full duplex has been forced (100baseTx-FD).  eepro100-diag -mf gives

[root@node16 build]# ./eepro100-diag -mf
eepro100-diag.c:v2.08 4/17/2002 Donald Becker (becker@scyld.com)
 http://www.scyld.com/diag/index.html
Index #1: Found a Intel i82557/8/9 EtherExpressPro100 adapter at 0xef00.
 MII PHY #1 transceiver registers:
  2100 780d 02a8 0154 05e1 0081 0000 0000
  0000 0000 0000 0000 0000 0000 0000 0000
  0a03 0000 0001 0000 0000 0000 0000 0000
  0000 0000 0b40 0000 0000 0000 0000 0000.
 MII PHY #1 transceiver registers:
   2100 780d 02a8 0154 05e1 0081 0000 0000
   0000 0000 0000 0000 0000 0000 0000 0000
   0a03 0000 0001 0000 0000 0000 0000 0000
   0000 0000 0b40 0000 0000 0000 0000 0000.
 Basic mode control register 0x2100: Auto-negotiation disabled!
   Speed fixed at 100 mbps, full-duplex.
 Basic mode status register 0x780d ... 780d.
   Link status: established.
   Capable of  100baseTx-FD 100baseTx 10baseT-FD 10baseT.
   Able to perform Auto-negotiation, negotiation not complete.
 Vendor ID is 00:aa:00:--:--:--, model 21 rev. 4.
   No specific information is known about this transceiver type.
 I'm advertising 05e1: Flow-control 100baseTx-FD 100baseTx 10baseT-FD 10baseT
   Advertising no additional info pages.
   IEEE 802.3 CSMA/CD protocol.
 Link partner capability is 0081: 100baseTx.
   Negotiation did not complete.



A tcpdump capture shows that the driver doesn't appear to be sending out the
correct packets when the failures occur.  The attachments follow.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ping -s 8000 from redhat machine to computer A
2. Observe that first packet is lost
3. ping -s 8000 again immediately.  Observe that no loss occurs
4. ping -s 8000 to computer B
5. Notice that first packet is lost.
6. Wait.
7. ping -s 8000 to computer A.
8. Notice that first packet is lost again.
	

Actual Results:  First packet is lost at the beginning of each cycle.

Expected Results:  No packet loss.

Additional info:

tcpdump captures to follow as attachments
Comment 1 Raphael Clifford 2002-05-22 13:12:30 EDT
Created attachment 58204 [details]
tcpdump capture of ping -s 8000 when first packet is lost
Comment 2 Raphael Clifford 2002-05-22 13:13:35 EDT
Created attachment 58205 [details]
tcpdump capture of ping -s 8000 when first packet is not lost (for comparison)
Comment 3 Jeff Garzik 2003-08-05 16:02:20 EDT
Is it possible to test the e100 driver in the latest errata kernel?
Comment 4 Raphael Clifford 2003-08-05 17:53:37 EDT
I'm afraid it has been too long since this bug was reported (May  2002).  I no
longer have access to the hardware.   The bug should probably be closed.

Note You need to log in before you can comment on or make changes to this bug.