This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 653559 - [RFE] installed-rpms should contain an easily sortable installation date and the distro
[RFE] installed-rpms should contain an easily sortable installation date and ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sos (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Pierre Carrier
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-15 12:17 EST by Pierre Carrier
Modified: 2010-11-15 17:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 17:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pierre Carrier 2010-11-15 12:17:15 EST
Description of problem:
- installed-rpms should contain %{INSTALLTIME} and %{DISTRIBUTION}
- This allows for easy sorting by installation date
- This simplifies determining where an RPM is from

Version-Release number of selected component (if applicable):
all

How reproducible:
100%

Steps to Reproduce:
1. look at installed-rpms in a sosreport
  
Actual results:
- Something similar to:
yelp-2.30.2-1.fc14.x86_64                                   Tue 02 Nov 2010 06:01:35 PM GMT


Expected results:
- Something similar to:
yelp-2.30.2-1.fc14.x86_64                                   Tue 02 Nov 2010 06:01:35 PM GMT	1288720895	Fedora Project
Comment 1 Pierre Carrier 2010-11-15 17:29:21 EST
Apart from a few exceptions, the VENDOR tag seems more consistent and more often defined in third-party repos than DISTRIBUTION.

One notable exception would be dpkg packages converted through alien, where DISTRIBUTION is kept and vendor dropped (tested with Debian packaged).

As usual, no strong opinion. Going with VENDOR for now, up for discussion.
Comment 2 Pierre Carrier 2010-11-15 17:55:12 EST
After discussing with pamadio, the intended change would not break http://checksysreport.com/
Comment 3 Pierre Carrier 2010-11-15 17:56:44 EST
Achieved with https://fedorahosted.org/sos/changeset/1003

Note You need to log in before you can comment on or make changes to this bug.