Bug 65363 - Xawtv QuickTime support not compiled in
Xawtv QuickTime support not compiled in
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xawtv (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 15:19 EDT by W. Michael Petullo
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-13 02:40:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2002-05-22 15:19:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020417

Description of problem:
The xawtv rpm included in RedHat Linux 7.3 does not have QuickTime support
compiled in.  Because of this, xawtv can not capture video into the QuickTime
format.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
streamer -f jpeg -F stereo -c /dev/v4l/video0 -o /tmp/foo.mov -t 3:30:00
	

Actual Results:  Xawtv printed the following rror message:

neither audio nor video format specified/found

Expected Results:  Xawtv should produce a QuickTime file

Additional info:

QuickTime is a nice framework and is interoperable with many important video
tools.  In my case, I capture using QuickTime so that I can edit my videos using
the Cinelerra video editor.

Xawtv uses Heroine Virtual's quicktime4linux library
(http://www.heroinewarrior.com/quicktime.php3) to provide QuickTime support. 
Historically, the group that wrote quicktime4linux uses a pretty closed
development process, though quicktime4linux is GPLed.  In order to provide a
compatible library using a more open environment, the libquicktime
(http://libquicktime.sourceforge.net/) project was started.  Libquicktime 0.9.0
was just released, and its tarball includes an rpm spec file.  Xawtv's author,
Gerd Knorr, now supports libquicktime instead of quicktime4linux.
Comment 1 Ngo Than 2002-06-07 09:31:42 EDT
i don't want to enable QuickTime support in xawtv, because it can cause patent 
problem with Apple.
Comment 2 W. Michael Petullo 2002-06-10 11:58:52 EDT
Are you sure this would cause patent problems?  I was thought that only certain
codecs were patented.  Libquicktime implements the core QuickTime code and
several  free (as far as I know) codecs.  I believe that free portions of
QuickTime should certainly be supported as it is a nice format for video
editing.  Xine, which is shipped with Red Hat Linux 7.3, already contains
QuickTime code similar to libquicktime's.
Comment 3 W. Michael Petullo 2002-07-13 02:40:46 EDT
From a libquicktime author:

As far as I know, Apple is aware of the quicktime libraries under linux
and even recommends them if people complain about missing linux support
from Apple Quicktime. The fileformat itself is free and quicktime
parsers can be released under the GPL without problems.

The only problematic thing is the opendivx codec, which contains
patented mpeg4 algorithms. As soon as we have an mp3 encoder, we'll have
another patented codec. The current strategy is to release such modules
only in source form. Maybe making a standard libquicktime package in
binary form (with all critical code removed) and additional source
packages (libquicktime-mp3, libquicktime-opendivx) would be enough.
Comment 4 Ngo Than 2002-08-26 16:59:51 EDT
we cannot add Quicktime support in Xawtv. Xine will be removed in next Red Hat
release too. Sorry for this issue.

Note You need to log in before you can comment on or make changes to this bug.