Bug 653806 - [abrt] ibus-1.3.7-11.fc14: XkbGetState: Process /usr/libexec/ibus-xkb was killed by signal 11 (SIGSEGV)
[abrt] ibus-1.3.7-11.fc14: XkbGetState: Process /usr/libexec/ibus-xkb was kil...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
14
i686 Unspecified
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:65ff1475df8026e03b940d1a6a6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-16 03:09 EST by Reinier Balt
Modified: 2010-11-23 16:52 EST (History)
3 users (show)

See Also:
Fixed In Version: ibus-1.3.7-14.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-22 04:12:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (8.79 KB, text/plain)
2010-11-16 03:09 EST, Reinier Balt
no flags Details

  None (edit)
Description Reinier Balt 2010-11-16 03:09:36 EST
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/libexec/ibus-xkb --get
comment: This report was here when I logged in
component: ibus
crash_function: XkbGetState
executable: /usr/libexec/ibus-xkb
kernel: 2.6.35.6-48.fc14.i686
package: ibus-1.3.7-11.fc14
rating: 4
reason: Process /usr/libexec/ibus-xkb was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1289811868
uid: 500
Comment 1 Reinier Balt 2010-11-16 03:09:38 EST
Created attachment 460769 [details]
File: backtrace
Comment 2 fujiwara 2010-11-16 03:37:05 EST
I know that issue but currently ibus-xkb is called by ibus panel only and it would need to open $DISPLAY.
I'm not sure why you'd like to run ibus-xkb with command line without $DISPLAY.
Comment 3 Reinier Balt 2010-11-16 03:48:42 EST
I did not run it myself. I logged in using nx. Perhaps the display was not ready while nx was starting?
Comment 4 fujiwara 2010-11-16 04:47:02 EST
(In reply to comment #3)
> I did not run it myself. I logged in using nx. Perhaps the display was not
> ready while nx was starting?

OK, I see. I don't try NoMachine. Probably ibus panel needs to retry to open the DISPLAY later from your reply.
Comment 5 fujiwara 2010-11-17 02:06:36 EST
I tried NX but I don't see any errors.

Installed rpms: NX Free Edition for Linux
nxclient-3.4.0-7.x86_64.rpm
nxnode-3.4.0-14.x86_64.rpm
nxserver-3.4.0-14.x86_64.rpm

NX server is Fedora14
NX client is Fedora13

server# /usr/NX/bin/nxserver --status
NX> 900 Connecting to server...
NX> 110 NX Server is running
NX> 999 Bye.

client% grep -i desktop $HOME/.nx/config/Fedora14.nxs
<option key="Custom Unix Desktop" value="console" />
<option key="Desktop" value="gnome" />
<option key="Virtual desktop" value="false" />

When I run the session, GNOME is launched.

/usr/NX/bin/nxclient --session "$HOME/.nx/config/Fedora14.nxs"

It seems the Free edition launch the en_US.UTF-8 and ibus is not executed by default.
So I guess you enabled ibus after you run im-chooser.
If ibus is not running, ibus-xkb is also not running and this bug won't be happened.

I could run ibus without any problems.

% ps -ef | grep ibus
% ibus-daemon --xim &
% env GTK_IM_MODULE=ibus gedit

I googled about NX and I guess you might use the old NX:
http://www.kanotix.com/files/fix/sidux/45xsession.orig

ibus could open DISPLAY in my session with NX.

% xauth list
localhost.localdomain:1002 MIT-MAGIC-COOKIE-1 0501ad....
server/unix:1002 MIT-MAGIC-COOKIE-1 0501ad....
server:1002 MIT-MAGIC-COOKIE-1 0501ad....
server/unix:3002 MIT-MAGIC-COOKIE-1 0501ad....

I wonder if your configuration would have a problem because if ibus-xkb crashes due to no display, ibus panel could be terminated due to no display before ibus-xkb is executed.

So I'd like to ask:
 - if there is no problem when you run ibus-daemon by manual.
 - if you have the display permission with xauth list.
 - if there are any errors in $HOME/.xsession-errors
Comment 6 fujiwara 2010-11-17 02:55:26 EST
I also recommend to disable selinux if you enabled it.
Comment 7 Fedora Update System 2010-11-22 04:04:47 EST
ibus-1.3.7-14.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-1.3.7-14.fc14
Comment 8 fujiwara 2010-11-22 04:12:45 EST
I would doubt your configuration.
But I modified ibus not to crash when ibus-xkb is executed by manual.
Comment 9 Reinier Balt 2010-11-22 08:57:01 EST
I haven't seen the bug reappear. I think it was a corner case, not regular case

regarding your questions:
- I've logged in using nx in a normal setup after install of FC14. I did not run ibus-daemon manually. Just tried, but no error (using 1.3.7-11)
- It might be the problem that nx was not started completely? Again, I was just logging in, not tampering with default $DISPLAY stuff.
- I have some errors. But I do not know if they are related because of the time lapse between the report and now:

gnome-screensaver: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
dropbox: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gdu-notification-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-volume-control-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gpk-update-icon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
polkit-gnome-authentication-agent-1: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gtk-window-decorator: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
abrt-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
bluetooth-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
nm-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

I'll report again if a similar crash happens and relate it to this report. Thanks for lookin into this report. Sorry for the late reply.
Comment 10 fujiwara 2010-11-22 20:15:36 EST
(In reply to comment #9)
> I haven't seen the bug reappear. I think it was a corner case, not regular case

OK, it's good to know the bug is not always reproduced.

> regarding your questions:
> - It might be the problem that nx was not started completely? Again, I was just
> logging in, not tampering with default $DISPLAY stuff.

Maybe but I'm not sure.
I guess the root cause is not ibus.

> gnome-screensaver: Fatal IO error 11 (Resource temporarily unavailable) on X
> server :0.0.

Hmm.., all errors are strange for me.
You might see the more information when you would run the applications by manual.

> I'll report again if a similar crash happens and relate it to this report.

ibus-xkb won't be crashed if you will upgrade to ibus 1.3.7-14 above.
However I guess it doesn't fix your root cause and you may see other errors.

Thanks.
Comment 11 Fedora Update System 2010-11-23 16:52:16 EST
ibus-1.3.7-14.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.